From 5299123e8acbfb89fb307d8bbb260501c258724a Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Thu, 19 May 2022 13:01:46 +0800
Subject: [PATCH] gnu: emacs-magit: Drop the libgit backend.
Drop the libgit backend for following reasons:
1. The libgit backend of Magitis very incomplete. There's almost no benefits,
but extra maintenance efforts.
2. The libgit backend of Magit can be considered as an extra package. And it's
still in Proof-Of-Concept status so its quaility doesn't satifised the
requirement of Guix package.
* gnu/packages/emacs-xyz.scm (emacs-magit)[arguments]: Use G-expressions.
<emacs>: Remove this argument.
<exclude>: Exclude the magit-libgit.el and magit-libgit-pkg.el.
<phases>: In phase 'patch-exec-paths', use search-input-file for perl
executable.
[inputs]: Remove emacs-libgit.
---
gnu/packages/emacs-xyz.scm | 95 ++++++++++++++++++++------------------
1 file changed, 49 insertions(+), 46 deletions(-)
@@ -869,57 +869,60 @@ (define-public emacs-magit
(base32 "0cxyvp2aav27znc7mf6c83q5pddpdniaqkrxn1r8dbgr540qmnpn"))))
(build-system emacs-build-system)
(arguments
- `(#:emacs ,emacs-no-x ;module support is required
- #:tests? #t
- #:test-command '("make" "test")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'build-info-manual
- (lambda _
- (invoke "make" "info")
- ;; Copy info files to the lisp directory, which acts as
- ;; the root of the project for the emacs-build-system.
- (for-each (lambda (f)
- (install-file f "lisp"))
- (find-files "Documentation" "\\.info$"))
- (chdir "lisp")))
- (add-after 'build-info-manual 'set-magit-version
- (lambda _
- (make-file-writable "magit.el")
- (emacs-substitute-variables "magit.el"
- ("magit-version" ,version))))
- (add-after 'set-magit-version 'patch-exec-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((perl (assoc-ref inputs "perl")))
- (make-file-writable "magit-sequence.el")
- (emacs-substitute-variables "magit-sequence.el"
- ("magit-perl-executable" (string-append perl "/bin/perl"))))))
- (add-before 'check 'configure-git
- (lambda _
- ;; Otherwise some tests fail with error "unable to auto-detect
- ;; email address".
- (setenv "HOME" (getcwd))
- (invoke "git" "config" "--global" "user.name" "toto")
- (invoke "git" "config" "--global" "user.email"
- "toto@toto.com")))
- (add-after 'configure-git 'disable-tramp-test
- (lambda _
- ;; There is an issue causing TRAMP to fail in the build
- ;; environment. Setting the tramp-remote-shell parameter of
- ;; the sudo-method to the file name of the shell didn't help.
- (chdir "..")
- (substitute* "t/magit-tests.el"
- (("^\\(ert-deftest magit-toplevel:tramp.*" all)
- (string-append all " (skip-unless nil)")))))
- (add-before 'install 'enter-lisp-directory
- (lambda _
- (chdir "lisp"))))))
+ (list
+ #:tests? #t
+ #:test-command #~(list "make" "test")
+ #:exclude #~(cons* "magit-libgit.el"
+ "magit-libgit-pkg.el"
+ %default-exclude)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'build-info-manual
+ (lambda _
+ (invoke "make" "info")
+ ;; Copy info files to the lisp directory, which acts as
+ ;; the root of the project for the emacs-build-system.
+ (for-each (lambda (f)
+ (install-file f "lisp"))
+ (find-files "Documentation" "\\.info$"))
+ (chdir "lisp")))
+ (add-after 'build-info-manual 'set-magit-version
+ (lambda _
+ (make-file-writable "magit.el")
+ (emacs-substitute-variables "magit.el"
+ ("magit-version" #$version))))
+ (add-after 'set-magit-version 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((perl (search-input-file inputs "/bin/perl")))
+ (make-file-writable "magit-sequence.el")
+ (emacs-substitute-variables "magit-sequence.el"
+ ("magit-perl-executable" perl)))))
+ (add-before 'check 'configure-git
+ (lambda _
+ ;; Otherwise some tests fail with error "unable to auto-detect
+ ;; email address".
+ (setenv "HOME" (getcwd))
+ (invoke "git" "config" "--global" "user.name" "toto")
+ (invoke "git" "config" "--global" "user.email"
+ "toto@toto.com")))
+ (add-after 'configure-git 'disable-tramp-test
+ (lambda _
+ ;; There is an issue causing TRAMP to fail in the build
+ ;; environment. Setting the tramp-remote-shell parameter of
+ ;; the sudo-method to the file name of the shell didn't help.
+ (chdir "..")
+ (substitute* "t/magit-tests.el"
+ (("^\\(ert-deftest magit-toplevel:tramp.*" all)
+ (string-append all " (skip-unless nil)")))))
+ (add-before 'install 'enter-lisp-directory
+ (lambda _
+ (chdir "lisp"))))))
(native-inputs
(list texinfo))
(inputs
(list git perl))
(propagated-inputs
- (list emacs-dash emacs-libgit emacs-transient emacs-with-editor))
+ (list emacs-dash emacs-transient emacs-with-editor))
(home-page "https://magit.vc/")
(synopsis "Emacs interface for the Git version control system")
(description
--
2.36.0