diff mbox series

[bug#45191] Improve reproducibility of package ECL

Message ID 867dpnwxx1.fsf@163.com
State Accepted
Headers show
Series [bug#45191] Improve reproducibility of package ECL | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao Dec. 12, 2020, 2:39 a.m. UTC
And fix a trivial issue(wrap phase didn't return #t)

Comments

Guillaume Le Vaillant Dec. 13, 2020, 1:24 p.m. UTC | #1
Zhu Zihao <all_but_last@163.com> skribis:

> +             (use-modules (ice-9 ftw))
> +             (let* ((lib (string-append (assoc-ref outputs "out") "/lib"))
> +                    (dir (car (scandir lib (lambda (x)
> +                                             (string-prefix? "ecl-" x))))))
> +               (delete-file (string-append lib "/" dir "/build-stamp")))

Wouldn't something like the following suffice?

--8<---------------cut here---------------start------------->8---
(delete-file (string-append (assoc-ref outputs "out")
                            "/lib/ecl-" ,version "/build-stamp"))
--8<---------------cut here---------------end--------------->8---
diff mbox series

Patch

From 94664b97a9696f3fd3dc2bbba04979c0f4b6a4d5 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 12 Dec 2020 10:34:37 +0800
Subject: [PATCH 2/2] gnu: ecl: Remove build-stamp to improve reproducibility.

* gnu/packages/lisp.scm(ecl)[arguments]<phases>: Add "remove-build-stamp" phase.
Move "wrap" phase after "remove-build-stamp" phase.
---
 gnu/packages/lisp.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4592724867..5805767721 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2019 Jesse Gildersleve <jessejohngildersleve@protonmail.com>
 ;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -258,7 +259,15 @@  interface to the Tk widget system.")
                     (contrib-asdf "contrib/asdf/asdf.lisp"))
                (copy-file guix-asdf contrib-asdf))
              #t))
-         (add-after 'install 'wrap
+         (add-after 'install 'remove-build-stamp
+           (lambda* (#:key outputs #:allow-other-keys)
+             (use-modules (ice-9 ftw))
+             (let* ((lib (string-append (assoc-ref outputs "out") "/lib"))
+                    (dir (car (scandir lib (lambda (x)
+                                             (string-prefix? "ecl-" x))))))
+               (delete-file (string-append lib "/" dir "/build-stamp")))
+             #t))
+         (add-after 'remove-build-stamp 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((ecl (assoc-ref outputs "out"))
                     (input-path (lambda (lib path)
-- 
2.29.2