diff mbox series

[bug#62200] gnu: Add emacs-nyxt.

Message ID 867cvixl4p.fsf@conses.eu
State New
Headers show
Series [bug#62200] gnu: Add emacs-nyxt. | expand

Commit Message

Miguel Ángel Moreno March 15, 2023, 12:19 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-nyxt): New variable.
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Nicolas Goaziou March 21, 2023, 9:04 a.m. UTC | #1
Hello,

conses <contact@conses.eu> writes:

> * gnu/packages/emacs-xyz.scm (emacs-nyxt): New variable.

Thank you.

> +    (synopsis "Interact with Nyxt from Emacs.")
> +    (description "This package consists of custom logic to interact with
> +Nyxt from Emacs.")

Should Nyxt be an input? In this case, you need to set `nyxt-path'
variable accordingly.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c067fe16c..fdd2202b3d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27498,6 +27498,27 @@  (define-public emacs-nix-mode
 comments.")
     (license license:lgpl2.1+)))
 
+(define-public emacs-nyxt
+  (package
+    (name "emacs-nyxt")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~conses/nyxt.el")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hgb10pk5m3v2gsl4h6i821nyzksss0rk4hhjnfb7nm98lalzbl6"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-sly))
+    (home-page "https://git.sr.ht/~conses/nyxt.el")
+    (synopsis "Interact with Nyxt from Emacs.")
+    (description "This package consists of custom logic to interact with
+Nyxt from Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-libmpdel
   (package
     (name "emacs-libmpdel")