diff mbox series

[bug#43906,v2] perl-alien-wxwidgets

Message ID 865z7esz81.fsf_-_@gmail.com
State New
Headers show
Series [bug#43906,v2] perl-alien-wxwidgets | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Malte Frank Gerdes Oct. 13, 2020, 7:27 p.m. UTC
Andreas Enge <andreas@enge.fr> writes:

> Hello,
>
> On Sat, Oct 10, 2020 at 03:52:17PM +0200, Malte Frank Gerdes wrote:
>> Subject: [PATCH 2/7] gnu: Add perl-alien-wxwidgets.
>
> during build, I see the following messages:
> starting phase `build'
> Building Alien-wxWidgets
> 'media' library not found: some functionality will be missing
>
> Does this matter? Should we add more inputs?

I checked that and (i'm also not a perl user, in fact i have never read
as much perl as in those packages in order to get slic3r :D) i can't
see any reason why it shouldn't find that library. It /is/ there. It's
part of wxwidgets. So i don't know what is going on there :/

> Then this:
> starting phase `check'
> t/01_load.t .......... ok
> t/zy_pod_coverage.t .. skipped: Test::Pod::Coverage 1.00 required for testing
> POD coverage
> t/zz_pod.t ........... skipped: Test::Pod 1.00 required for testing POD
>
> Similarly, add (native-)inputs?

As Tobias said, it might be perfectly fine to ignore these. I added the
relevant bits nonetheless, because it might be of help sometimes (or not
:D).

> Concerning these, I ran this command:
> $ guix gc --references
> /gnu/store/r8lbv88cg2nqkk0a2hjcvrs0z3ljqrcy-perl-alien-wxwidgets-0.69
> /gnu/store/a41jn9pcrgpkgba6vpd3m56r0fsczsv2-wxwidgets-gtk2-3.0.5.1
> /gnu/store/r8lbv88cg2nqkk0a2hjcvrs0z3ljqrcy-perl-alien-wxwidgets-0.69
>
> So wxwidgets-gtk2 should be a normal, non-native input.
> Why -gtk2? Does this warrant a comment?

i don't know why i chose wxwidgets-gtk2 - it works perfectly fine with
wxwidgets, sorry!

> I would suggest insignificantly beefed up descriptive fields:
>     (synopsis "Module for building, finding and using wxWidgets binaries")
>     (description "Alien::wxWidgets can be used to detect and get configuration
> settings from an installed wxWidgets package.")

I have modified the patch according to your suggestions.


Malte
diff mbox series

Patch

From bedffb896dba772bfcc8d2af05fb3bbacfeb6e08 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:07:50 +0200
Subject: [PATCH] gnu: Add perl-alien-wxwidgets.

* gnu/packages/perl.scm (perl-alien-wxwidgets): New variable.
---
 gnu/packages/perl.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9916c579e4..34a84ab2fb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -76,6 +76,7 @@ 
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages video)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages wxwidgets)
   #:use-module (gnu packages xorg))
 
 ;;;
@@ -386,6 +387,35 @@  possibility to download and install prebuilt binaries or to build SDL & co.@:
 from source codes.")
     (license license:perl-license)))
 
+(define-public perl-alien-wxwidgets
+  (package
+    (name "perl-alien-wxwidgets")
+    (version "0.69")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/M/MD/MDOOTSON/Alien-wxWidgets-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0jg2dmkzhj03f6b0vmv597yryfw9cclsdn9ynvvlrzzgpd5lw8jk"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-lwp-protocol-https" ,perl-lwp-protocol-https)
+       ("perl-module-build" ,perl-module-build)
+       ("perl-test-pod" ,perl-test-pod)
+       ("perl-test-pod-coverage" ,perl-test-pod-coverage)
+       ("wxwidgets" ,wxwidgets)))
+    (propagated-inputs
+     `(("perl-module-pluggable" ,perl-module-pluggable)))
+    (home-page "https://metacpan.org/release/Alien-wxWidgets")
+    (synopsis "Module for building, finding and using wxWidgets binaries")
+    (description "Alien::wxWidgets can be used to detect and get configuration
+settings from an installed wxWidgets package.")
+    (license license:perl-license)))
+
 (define-public perl-any-moose
   (package
     (name "perl-any-moose")
-- 
2.28.0