diff mbox series

[bug#49493] : gnu: emacs-telega: Fix 'patch-source' phase.

Message ID 865yxjo7fa.fsf@163.com
State Accepted
Headers show
Series [bug#49493] : gnu: emacs-telega: Fix 'patch-source' phase. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao July 9, 2021, 3:04 p.m. UTC
'patch-source' phase will replace binary name with wrong full path name
(e.g. ffmpeg => /gnu/store/<hash>-ffmpeg-X.Ybin/ffmpeg)

This patch attempts to fix this issue, and also add missing
'telega-vvnote.el' to patch targets.

Comments

Leo Prikler July 9, 2021, 3:59 p.m. UTC | #1
Am Freitag, den 09.07.2021, 23:04 +0800 schrieb Zhu Zihao:
> 'patch-source' phase will replace binary name with wrong full path
> name
> (e.g. ffmpeg => /gnu/store/<hash>-ffmpeg-X.Ybin/ffmpeg)
> 
> This patch attempts to fix this issue, and also add missing
> 'telega-vvnote.el' to patch targets.
Thanks for catching this.  I've simplified your patch and pushed it.

Regards,
Leo
diff mbox series

Patch

From f63d44007a89f13ff9e23bbf0b8fb22ee4d94dcb Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Fri, 9 Jul 2021 22:58:34 +0800
Subject: [PATCH] gnu: emacs-telega: Fix 'patch-source' phase.

* gnu/packages/emacs-xyz.scm(emacs-telega):

[arguments]<phases>: Add missing slash in file name.

Patch telega-vvnote.el.
---
 gnu/packages/emacs-xyz.scm | 30 +++++++++++++++++++-----------
 1 file changed, 19 insertions(+), 11 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6ac61fd596..0770795044 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26290,17 +26290,25 @@  service, and connect it with Emacs via inter-process communication.")
              (let* ((ffmpeg (assoc-ref inputs "ffmpeg"))
                     (ffmpeg-bin (string-append ffmpeg "/bin/ffmpeg"))
                     (ffplay-bin (string-append ffmpeg "/bin/ffplay")))
-              (substitute* "telega-ffplay.el"
-                (("(shell-command-to-string\|concat) \"(ffmpeg\|ffprobe)"
-                  all func cmd)
-                 (string-append func " \"" (assoc-ref inputs "ffmpeg")
-                                "bin/" cmd))
-                (("\\(executable-find \"ffplay\"\\)")
-                 (string-append "(and (file-executable-p \"" ffplay-bin "\")"
-                                "\"" ffplay-bin "\")"))
-                (("\\(executable-find \"ffmpeg\"\\)")
-                 (string-append "(and (file-executable-p \"" ffmpeg-bin "\")"
-                                "\"" ffmpeg-bin "\")"))))))
+
+               (define targets
+                 '("telega-ffplay.el" "telega-vvnote.el"))
+
+               (define (patch-ffmpeg file)
+                 (substitute* file
+                   (("(shell-command-to-string\|concat) \"(ffmpeg\|ffprobe)"
+                     all func cmd)
+                    (string-append func " \"" (assoc-ref inputs "ffmpeg")
+                                   "/bin/" cmd))
+                   (("\\(executable-find \"ffplay\"\\)")
+                    (string-append "(and (file-executable-p \"" ffplay-bin "\")"
+                                   "\"" ffplay-bin "\")"))
+                   (("\\(executable-find \"ffmpeg\"\\)")
+                    (string-append "(and (file-executable-p \"" ffmpeg-bin "\")"
+                                   "\"" ffmpeg-bin "\")"))))
+
+               (for-each patch-ffmpeg targets)
+               #t)))
          (add-after 'unpack 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (substitute* "telega-server.el"
-- 
2.32.0