diff mbox series

[bug#55147] v2 gnu: emacs-plz: Update to 0.1.

Message ID 8647ddd5137541d5950fd75c9a1c5fffe90778cc.1652643372.git.avityazev@posteo.org
State Accepted
Headers show
Series [bug#55147] v2 gnu: emacs-plz: Update to 0.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev May 15, 2022, 7:37 p.m. UTC
* gnu/packages/emacs-xyz (emacs-plz): Update to 0.1.
[source]: Use elpa instead of github.
---
 gnu/packages/emacs-xyz.scm | 38 +++++++++++++++++---------------------
 1 file changed, 17 insertions(+), 21 deletions(-)

Comments

Nicolas Goaziou June 7, 2022, 7:46 p.m. UTC | #1
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

> * gnu/packages/emacs-xyz (emacs-plz): Update to 0.1.
> [source]: Use elpa instead of github.

We refrain from using ELPA as upstream because they have the habit of
removing old tarballs without warnings.

So I applied your patch, with Github as upstream.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8a319fc0ff..7a5c6235fc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15710,29 +15710,25 @@  (define-public emacs-emamux
     (license license:gpl3+)))
 
 (define-public emacs-plz
-  (let ((commit "7e456638a651bab3a814e3ea81742dd917509cbb")
-        (revision "1"))
-    (package
-      (name "emacs-plz")
-      (version (git-version "0.1-pre" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/alphapapa/plz.el")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "05kgxrps1s20im5hhq799nrs3615bvssm4r0ysgmwm203mmzsjgj"))))
-      (build-system emacs-build-system)
-      (inputs (list curl))
-      (home-page "https://github.com/alphapapa/plz.el")
-      (synopsis "HTTP library for Emacs")
-      (description
-       "This package provides HTTP library for Emacs.  It uses curl as
+  (package
+    (name "emacs-plz")
+    (version "0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://elpa.gnu.org/packages/plz-" version ".tar"))
+       (sha256
+        (base32 "083qz6kfg4q8xy3vsfwlk2g9vbg8iym2axmyhh54naivrc096ghc"))))
+    (build-system emacs-build-system)
+    (inputs (list curl))
+    (home-page "https://github.com/alphapapa/plz.el")
+    (synopsis "HTTP library for Emacs")
+    (description
+     "This package provides HTTP library for Emacs.  It uses curl as
 a backend, which avoids some of the issues with using Emacs’s built-in url
 library.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-ement
   (let ((commit "c951737dc855604aba389166bb0e7366afadc533")