diff mbox series

[bug#54261] Acknowledgement ([PATCH]: Update GTK to 4.6.1.)

Message ID 8635jjfcgz.fsf@163.com
State Accepted
Headers show
Series [bug#54261] Acknowledgement ([PATCH]: Update GTK to 4.6.1.) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao March 15, 2022, 3:42 p.m. UTC
Also update gtkmm and pangomm.

Comments

Ludovic Courtès March 18, 2022, 10:48 p.m. UTC | #1
Hi,

The patches all LGTM, but unfortunately they break fcitx5-gtk, which
pulls in both ‘pango’ and ‘pango-next’, leading to:

--8<---------------cut here---------------start------------->8---
-- Checking for module 'gtk+-3.0'
--   Found gtk+-3.0, version 3.24.30
-- Checking for module 'gdk-3.0'
--   Found gdk-3.0, version 3.24.30
-- Checking for module 'gdk-x11-3.0'
--   Found gdk-x11-3.0, version 3.24.30
-- Checking for module 'gtk4>=4.2'
--   Package 'gtk4' requires 'pango >= 1.50.0' but version of pango is 1.48.10
CMake Error at /gnu/store/zga679c4nldah9l8dhd5a4hdy820hcyf-cmake-minimal-3.21.4/share/cmake-3.21/Modules/FindPkgConfig.cmake:562 (message):
  A required package was not found
Call Stack (most recent call first):
  /gnu/store/zga679c4nldah9l8dhd5a4hdy820hcyf-cmake-minimal-3.21.4/share/cmake-3.21/Modules/FindPkgConfig.cmake:784 (_pkg_check_modules_internal)
  gtk4/CMakeLists.txt:10 (pkg_check_modules)
--8<---------------cut here---------------end--------------->8---

Solutions that come to mind:

  1. Disable the GTK 4 backend of ‘fcitx5-gtk’.

  2. Add ‘pango-next’ as an input of ‘fcitx5-gtk’, taking precedence
     over ‘pango’, at the risk of breaking the GTK+2 and GTK+3
     backends.

  3. There is no 3rd idea.

Thoughts?

Ludo’.
Zhu Zihao March 19, 2022, 3 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:


>   3. There is no 3rd idea.
>
> Thoughts?
>
> Ludo’.

3. I'll reconsider your proposal in recent fcitx5-gtk update that split
the gtk4 backend into a separated package.
diff mbox series

Patch

From dc4aabc7831c00526f0b2b2c3e69cab4aa5f3459 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Tue, 15 Mar 2022 22:40:27 +0800
Subject: [PATCH 4/4] gnu: gtkmm: Update to 4.6.0.

* gnu/packages/gtk.scm (gtkmm): Update to 4.6.0.
---
 gnu/packages/gtk.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2ee273229f..75d4120e7e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1760,7 +1760,7 @@  (define-public atkmm-2.28
 (define-public gtkmm
   (package
     (name "gtkmm")
-    (version "4.4.0")
+    (version "4.6.0")
     (source
      (origin
        (method url-fetch)
@@ -1769,7 +1769,7 @@  (define-public gtkmm
                        (version-major+minor version)  "/"
                        name "-" version ".tar.xz"))
        (sha256
-        (base32 "1nhdf1s437k41af6frbqw2sky46qci0hgkg9h86a9rlnc0r69d1f"))))
+        (base32 "07sch42iavk5fw3r9x5m0kb2l4xg1ch3vn85mksiwmybjf8a0lqk"))))
     (build-system meson-build-system)
     (outputs '("out" "doc"))
     (arguments
-- 
2.34.0