diff mbox series

[bug#44045,10/10,v2] WIP Ultimaker Cura

Message ID 861rhrlleo.fsf@gmail.com
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Malte Frank Gerdes Oct. 21, 2020, 2:10 p.m. UTC
Efraim Flashner <efraim@flashner.co.il> writes:

> On Sat, Oct 17, 2020 at 12:32:30PM +0200, Malte Frank Gerdes wrote:
>> Hi,
>> 
>> this series adds Ultimakers Cura software to Guix. It's WIP because the cura
>> program itself segfaults while starting and i am not getting further as to why
>> this happens. It would be great if someone interested could take a look :-)
>> 
>> The trimesh python library cannot be built, because pyinstrument-cext can't be
>> built. This is due to the fact that the used URLs to fetch the source archive
>> don't exist. I have yet to find out how they are generated.
>
> for pyinstrument-cext, try replacing the string in pypi-uri to
> "pyinstrument_cext", with an underscore.

Thanks for the s/-/_/ tip! This works :-)

Having that out of the way i noticed that trimesh's testsuite dependes
(for whatever reason) on a javascript library which has to be generated
via npm, which is currently not available in Guix. Therefore i disabled
the testsuite from trimesh.

Attached is a corresponding patch.


Malte
diff mbox series

Patch

From c39889e9a89662d702d8149c5d9600122e099209 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Sat, 17 Oct 2020 12:04:29 +0200
Subject: [PATCH] gnu: Add python-trimesh.

* gnu/packages/python-science.scm (python-trimesh): New variable.
---
 gnu/packages/python-science.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 101c8fb640..738ac1111e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,6 +36,7 @@ 
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages sphinx)
@@ -285,6 +287,37 @@  logic, also known as grey logic.")
 of the SGP4 satellite tracking algorithm.")
     (license license:expat)))
 
+(define-public python-trimesh
+  (package
+  (name "python-trimesh")
+  (version "3.8.11")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "trimesh" version))
+      (sha256
+        (base32
+          "1pi7v9rdaakjfrqpc3zk77pg3z6vaz7qh1wy322sj9bq4824h2vr"))))
+  (build-system python-build-system)
+  (propagated-inputs
+    `(("python-numpy" ,python-numpy)
+      ("python-setuptools" ,python-setuptools)))
+  (native-inputs
+    `(("python-coveralls" ,python-coveralls)
+      ("python-pytest" ,python-pytest)
+      ("python-pytest-cov" ,python-pytest-cov)))
+  (arguments
+   `(;; tests need to be disabled because pyinstrument
+     ;; can't be built, because it depends on npm for
+     ;; JS generation.
+     #:tests? #false))
+  (home-page "https://github.com/mikedh/trimesh")
+  (synopsis
+    "Import, export, process, analyze and view triangular meshes.")
+  (description
+    "Import, export, process, analyze and view triangular meshes.")
+  (license license:expat)))
+
 (define-public python-pandas
   (package
     (name "python-pandas")
-- 
2.28.0