diff mbox series

[bug#61084,v2] gnu: Add emacs-clj-deps-new.

Message ID 861qne4he7.fsf@conses.eu
State New
Headers show
Series [bug#61084,v2] gnu: Add emacs-clj-deps-new. | expand

Commit Message

Miguel Ángel Moreno Jan. 28, 2023, 6:56 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-clj-deps-new): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Nicolas Goaziou Jan. 29, 2023, 2:44 p.m. UTC | #1
Hello,

conses <contact@conses.eu> writes:

> * gnu/packages/emacs-xyz.scm (emacs-clj-deps-new): New variable.

Thank you. I applied it with the minor changes below.

> +(define-public emacs-clj-deps-new
> +  (let ((version "1.1")

We hard-code version in `git-version' call below, so I removed this
binding.

> +        (commit "e1cf65eb040f5a2e9a3eca970044ba71cc53fb27")
> +        (revision "0"))
> +    (package
> +      (name "emacs-clj-deps-new")
> +      (version (git-version version revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/jpe90/emacs-clj-deps-new")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                  "03db3l5klc20wgdaj44scgjfi2mha85bip07ls6pwbi039ls7rvx"))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs (list emacs-transient))
> +      (home-page "https://github.com/jpe90/emacs-clj-deps-new")
> +      (synopsis "Create Clojure projects from templates")
> +      (description
> +       "This is a small wrapper around the
> +@uref{https://github.com/seancorfield/deps-new, deps-new} and
> +@uref{https://github.com/seancorfield/clj-new, clj-new} tools for creating
> +Clojure projects from templates.")
> +      (license license:gpl3))))

License is actually GPL3+, since the library header contains:

  either version 3 of the License, or (at your option) any later version.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc378581f5..0d3316e6a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11688,6 +11688,33 @@  (define-public emacs-clojure-mode
 It is recommended to use @code{clojure-mode} with Paredit or Smartparens.")
     (license license:gpl3+)))
 
+(define-public emacs-clj-deps-new
+  (let ((version "1.1")
+        (commit "e1cf65eb040f5a2e9a3eca970044ba71cc53fb27")
+        (revision "0"))
+    (package
+      (name "emacs-clj-deps-new")
+      (version (git-version version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jpe90/emacs-clj-deps-new")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "03db3l5klc20wgdaj44scgjfi2mha85bip07ls6pwbi039ls7rvx"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-transient))
+      (home-page "https://github.com/jpe90/emacs-clj-deps-new")
+      (synopsis "Create Clojure projects from templates")
+      (description
+       "This is a small wrapper around the
+@uref{https://github.com/seancorfield/deps-new, deps-new} and
+@uref{https://github.com/seancorfield/clj-new, clj-new} tools for creating
+Clojure projects from templates.")
+      (license license:gpl3))))
+
 (define-public emacs-clj-refactor
   (package
     (name "emacs-clj-refactor")