diff mbox series

[bug#74495,02/16] gnu: Add go-github-com-aymanbagabas-go-udiff.

Message ID 860105737bc46811ebf02673fe44b3a3ea0bf08d.1732386154.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-noahgorstein-jqp. | expand

Commit Message

Artyom V. Poptsov Nov. 23, 2024, 6:28 p.m. UTC
* gnu/packages/golang.scm (go-github-com-aymanbagabas-go-udiff): New variable.

Change-Id: Icac934589b041c9b3b5db0114173d25d0c3f4c34
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9b3a672887..8dd8350847 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7287,6 +7287,34 @@  (define-public go-github-com-mtibben-androiddnsfix
 (define-public go-github-com-androiddnsfix
   (deprecated-package "go-github-com-androiddnsfix" go-github-com-mtibben-androiddnsfix))
 
+(define-public go-github-com-aymanbagabas-go-udiff
+  (package
+    (name "go-github-com-aymanbagabas-go-udiff")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aymanbagabas/go-udiff")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09p17r8s5flhq6p69z08345q0y99dpb0yyashlwpgxn45xir7y6g"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/aymanbagabas/go-udiff"))
+    (home-page "https://github.com/aymanbagabas/go-udiff")
+    (synopsis "Diffing library for Golang")
+    (description
+     "@code{udiff} (micro-diff, or µDiff) is a library that implements the
+@url{http://www.xmailserver.org/diff2.pdf, Myers' diffing algorithm}.  It aims to
+provide a minimal API to compute and apply diffs with zero dependencies.  It also
+supports generating diffs in the
+@url{https://www.gnu.org/software/diffutils/manual/html_node/Unified-Format.html,
+Unified Format}.")
+    (license license:expat)))
+
 (define-public go-gopkg-in-ini
   (package
     (name "go-gopkg-in-ini")