diff mbox series

[bug#36576] gnu: shroud: Update to 0.1.2

Message ID 85sgrenetp.fsf@disroot.org
State Accepted
Headers show
Series [bug#36576] gnu: shroud: Update to 0.1.2 | expand

Commit Message

Amar M. Singh July 10, 2019, 2:29 p.m. UTC
Shroud now builds with Guile-2.2.

Comments

Tobias Geerinckx-Rice July 10, 2019, 2:51 p.m. UTC | #1
Amar,

Amar Singh wrote:
> Shroud now builds with Guile-2.2.

Thanks!

I've merged this with your previous bug.  If you use git 
send-email, you can add patches to an existing bug report with 
‘git send-email --to=nnnnn@debbugs.gnu.org …’.

Kind regards,

T G-R
diff mbox series

Patch

From 21bb1505f663084584ab5d61f32a6b168f64f3ca Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Wed, 10 Jul 2019 19:57:29 +0530
Subject: [PATCH] gnu: shroud: Update to 0.1.2.

* gnu/packages/password-utils.scm (shroud): Update to 0.1.2.

Shroud now builds with Guile-2.2.
---
 gnu/packages/password-utils.scm | 42 +++++++++++++++++++++++++--------
 1 file changed, 32 insertions(+), 10 deletions(-)

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 49024b26c4..5c3cff64c9 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -50,6 +50,7 @@ 
   #:use-module (gnu packages admin)
   #:use-module (gnu packages aidc)
   #:use-module (gnu packages authentication)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -236,28 +237,49 @@  platforms.")
 (define-public shroud
   (package
     (name "shroud")
-    (version "0.1.1")
+    (version "0.1.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://files.dthompson.us/shroud/shroud-"
-                                  version ".tar.gz"))
+              (uri (string-append "https://files.dthompson.us/"
+                                  name "/shroud-" version ".tar.gz"))
               (sha256
                (base32
-                "1y43yhgy2zbrk5bqj3qyx9rkcz2bma9sinlrg7dip3jqms9gq4lr"))))
+                "1l2shrhvcwfzkar9qiwb75nhcqmx25iz55lzmz0c187nbjhqzi9p"))))
     (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("autoconf" ,autoconf-wrapper)
+       ("automake" ,automake)
+       ("gettext" ,gettext-minimal)))
     (arguments
-     '(#:phases
+     `(#:modules ((guix build gnu-build-system)
+                  (guix build utils)
+                  (ice-9 popen)
+                  (ice-9 rdelim)
+                  (srfi srfi-26))
+       #:phases
        (modify-phases %standard-phases
          (add-after 'install 'wrap-shroud
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out       (assoc-ref outputs "out"))
-                    (ccachedir (string-append out "/lib/guile/2.0/ccache"))
-                    (prog      (string-append out "/bin/shroud")))
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (guile (assoc-ref inputs "guile"))
+                    (xclip (assoc-ref inputs "xclip"))
+                    (prog (string-append out "/bin/shroud"))
+                    (deps (list xclip))
+                    (effective (read-line
+                                (open-pipe* OPEN_READ
+                                            (string-append guile "/bin/guile")
+                                            "-c" "(display (effective-version))")))
+                    (path (map (cut string-append <> "/bin")
+                               (delete #f deps)))
+                    (ccachedir (string-append out
+                                              "/lib/guile/" effective "/site-ccache")))
                (wrap-program prog
+                 `("PATH" ":" prefix ,path)
                  `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
                #t))))))
     (inputs
-     `(("guile" ,guile-2.0)
+     `(("guile" ,guile-2.2)
        ("gnupg" ,gnupg)
        ("xclip" ,xclip)))
     (synopsis "GnuPG-based secret manager")
-- 
2.22.0