diff mbox series

[bug#53578] gnu: Add a new package: gnusim8085

Message ID 85o83x35p8.fsf@airmail.cc
State Accepted
Headers show
Series [bug#53578] gnu: Add a new package: gnusim8085 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Bird Jan. 27, 2022, 9:09 a.m. UTC
Hello,

The attached patch adds gnusim8085, a simulator for the 8085 processor.

Thanks!

Comments

Bird Jan. 27, 2022, 10:48 a.m. UTC | #1
Sorry, but this package looks like it won't work yet.
Please wait till i fix that.

Thanks
Bird Jan. 27, 2022, 5:26 p.m. UTC | #2
Bird <birdsite@airmail.cc> writes:

> Sorry, but this package looks like it won't work yet.
> Please wait till i fix that.

This turned out to be an upstream issue.
(Having to save the file before executing and
also not repeatedly re-running the same error-generating program)

I think the package is okay to be included.
Ludovic Courtès March 7, 2022, 8:45 p.m. UTC | #3
Hi,

Bird <birdsite@airmail.cc> skribis:

>>From 811a6563328a706dd43072b958c08e63f23341d7 Mon Sep 17 00:00:00 2001
> From: Bird <birdsite@airmail.cc>
> Date: Thu, 27 Jan 2022 09:05:21 +0000
> Subject: [PATCH] gnu: Add a new package: gnusim8085
>
> * gnu/packages/emulators.scm(gnusim8085): Add the package.

Applied.  I tweaked the indentation, changed the license to ‘gpl2+’
(because source file headers explicitly say “or any later version”), and
remove “Windows and GNU/Linux” from the description (it’s irrelevant
from the POV of Guix users.)

Thanks!

Ludo’.
diff mbox series

Patch

From 811a6563328a706dd43072b958c08e63f23341d7 Mon Sep 17 00:00:00 2001
From: Bird <birdsite@airmail.cc>
Date: Thu, 27 Jan 2022 09:05:21 +0000
Subject: [PATCH] gnu: Add a new package: gnusim8085

* gnu/packages/emulators.scm(gnusim8085): Add the package.
---
 gnu/packages/emulators.scm        | 38 +++++++++++++++++++++++++++++++
 gnu/packages/statistics.go.ne50NV |  0
 2 files changed, 38 insertions(+)
 create mode 100644 gnu/packages/statistics.go.ne50NV

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index b260ca38f7..90ebd7c4b0 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -73,6 +73,7 @@  (define-module (gnu packages emulators)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages libedit)
@@ -1954,6 +1955,43 @@  (define-public gnome-arcade
 emulator.")
     (license license:gpl3+)))
 
+(define-public gnusim8085
+  (package
+   (name "gnusim8085")
+   (version "1.4.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+	   "https://github.com/srid/GNUSim8085/releases/download/"
+           version "/" name "-" version ".tar.gz"))
+     (sha256
+      (base32
+       "05x0is0ckagb3r74p6lw9b8nqrrh7q2v4jvc4cnhljchz9x7kw2a"))))
+   (native-inputs (list pkg-config))
+   (inputs (list gtksourceview-3 adwaita-icon-theme ))
+   (build-system glib-or-gtk-build-system)
+   (home-page "https://gnusim8085.srid.ca")
+   (synopsis "Graphical simulator, assembler and debugger for the
+Intel 8085 microprocessor")
+   (description "GNUSim8085 is a graphical simulator,
+assembler and debugger for the Intel 8085 microprocessor
+in GNU/Linux and Windows.
+@itemize
+@item A simple editor component with syntax highlighting.
+@item A keypad to input assembly language instructions with appropriate arguments.
+@item Easy view of register contents.
+@item Easy view of flag contents.
+@item Hexadecimal <–> Decimal converter.
+@item View of stack, memory and I/O contents.
+@item Support for breakpoints for program debugging.
+@item Stepwise program execution.
+@item One click conversion of assembly program to opcode listing.
+@item Printing support.
+@item UI translated in various languages.
+@end itemize")
+   (license license:gpl2)))
+
 (define-public pcsxr
   ;; No release since 2017.
   (let ((commit "6484236cb0281e8040ff6c8078c87899a3407534"))
diff --git a/gnu/packages/statistics.go.ne50NV b/gnu/packages/statistics.go.ne50NV
new file mode 100644
index 0000000000..e69de29bb2

base-commit: e60b10fd99c490b42f2a25003f4c7a9c49668bb8
-- 
2.34.0