From 06b1b2d4567adf27d4e980bcdf9c2886d9afdcbd Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Mon, 22 Apr 2019 01:28:32 +0530
Subject: [PATCH] gnu: Add emacs-shroud.
* gnu/packages/emacs-xyz.scm (emacs-shroud): New variable.
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -15620,3 +15620,33 @@ verb commands which would are normally destructive (such as deletion) are
provided. Those alternative commands are and bound by default to their
corresponding Evil keys.")
(license license:expat))))
+
+(define-public emacs-shroud
+ (package
+ (name "emacs-shroud")
+ (version "1.15.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/o-nly/emacs-shroud.git")
+ (commit version)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32
+ "0wvm4lxqcc1p8v7rpqal3bnqgnpk1gs7v18i83f6cvi5d88jkgdg"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("shroud" ,shroud)
+ ("emacs-f" ,emacs-f)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-s" ,emacs-s)
+ ("emacs-bui" ,emacs-bui)
+ ("gnupg" ,gnupg)))
+ (home-page "http://git.nly.info.tm:9001/shroud.git")
+ (synopsis "Emacs interface for Shroud password manager")
+ (description
+ "Provides Emacs interface to the Shroud password manager.")
+ (license license:gpl3+)))
--
2.21.0