diff mbox series

[bug#40038] gnu: Add guile-torrent.

Message ID 85eetxdefs.fsf@disroot.org
State Accepted
Headers show
Series [bug#40038] gnu: Add guile-torrent. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Amar M. Singh March 12, 2020, 11:01 a.m. UTC
This is an alpha package provides facilities for working with `.torrent'
or metainfo files. Implements a bencode reader and writer according to
Bitorrent BEP003, also provides a s-expression syntax for writing
metainfo.

Note: I am aware that there might be a naming-conflict with another
module "Guile-Torrent" that roptat is working on.

Thanks,
Amar

Comments

Mathieu Othacehe March 12, 2020, 11:54 a.m. UTC | #1
Hello Amar,

Thanks for this patch.

;;; Copyright © 2019 Amar Singh <nly@disroot.org>

Don't forget to update your copyright.

+(define-public guile-torrent
+  (package (name "guile-torrent")
            ^
            This should be on the next line.

+   (version "0.1-preview")
+   (source (origin (method git-fetch)
+                   (uri (git-reference
+                         (url
+                          "https://github.com/o-nly/torrent.git")
+                         (commit version)))
+                   (file-name (git-file-name name version))
+                   (sha256
+                    (base32
+                     "0rim8gr0cpnm1lixihsjpzg5z3i44vhqgj0dv6z7xj6jiwrmi9pw"))))
+   (build-system gnu-build-system)
+   (native-inputs
+    `(("autoconf" ,autoconf)
+      ("automake" ,automake)
+      ("guile" ,guile-2.2)
+      ("texinfo" ,texinfo)
+      ("perl" ,perl)
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("guile-gcrypt" ,guile-gcrypt)))

guile-gcrypt probably needs to be a propagated-input.

+   (home-page "https://github.com/o-nly/torrent")
+   (synopsis "Torrent library for GNU Guile")
+   (description
+    "This package provides facilities for working with `.torrent' or metainfo
+files. Implements a bencode reader and writer according to Bitorrent BEP003.")

You can squash the other patch you sent fixing the description with this
one.

Mathieu
diff mbox series

Patch

From 67516dd69842b483f7c05dd6048561053bcce37c Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Thu, 12 Mar 2020 16:25:33 +0530
Subject: [PATCH] gnu: Add guile-torrent.

* gnu/packages/guile-xyz.scm (guile-torrent): New variable.
---
 gnu/packages/guile-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 37a5198e4e..7880e29b20 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3109,3 +3109,32 @@  currently a re-implementation of the lentes library for Clojure.  Lenses
 provide composable procedures, which can be used to focus, apply functions
 over, or update a value in arbitrary data structures.")
       (license license:gpl3+))))
+
+(define-public guile-torrent
+  (package (name "guile-torrent")
+   (version "0.1-preview")
+   (source (origin (method git-fetch)
+                   (uri (git-reference
+                         (url
+                          "https://github.com/o-nly/torrent.git")
+                         (commit version)))
+                   (file-name (git-file-name name version))
+                   (sha256
+                    (base32
+                     "0rim8gr0cpnm1lixihsjpzg5z3i44vhqgj0dv6z7xj6jiwrmi9pw"))))
+   (build-system gnu-build-system)
+   (native-inputs
+    `(("autoconf" ,autoconf)
+      ("automake" ,automake)
+      ("guile" ,guile-2.2)
+      ("texinfo" ,texinfo)
+      ("perl" ,perl)
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("guile-gcrypt" ,guile-gcrypt)))
+   (home-page "https://github.com/o-nly/torrent")
+   (synopsis "Torrent library for GNU Guile")
+   (description
+    "This package provides facilities for working with `.torrent' or metainfo
+files. Implements a bencode reader and writer according to Bitorrent BEP003.")
+   (license license:gpl3+)))
-- 
2.25.1