diff mbox series

[bug#64180] gnu: python-pyvista: Update to 0.39.1.

Message ID 85e708ef4a9968f9425ef5be184d5fcf5488da36.1687218540.git.paul@apatience.com
State New
Headers show
Series [bug#64180] gnu: python-pyvista: Update to 0.39.1. | expand

Commit Message

Paul A. Patience June 20, 2023, midnight UTC
* gnu/packages/python-science.scm (python-pyvista): Update to 0.39.1.
[propagated-inputs]: Add python-pooch, remove python-appdirs.
---
 gnu/packages/python-science.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)


base-commit: d884fc9e2efecfba09af4694f5a13ad7fc6f704f

Comments

Christopher Baines June 20, 2023, 9:34 p.m. UTC | #1
"Paul A. Patience" <paul@apatience.com> writes:

> * gnu/packages/python-science.scm (python-pyvista): Update to 0.39.1.
> [propagated-inputs]: Add python-pooch, remove python-appdirs.
> ---
>  gnu/packages/python-science.scm | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)

Thanks for the patch, I've pushed it to master as
24fc0d506a046adb5331a5e2626830af0008406b.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7d3319e367..a8e43d96cf 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1341,7 +1341,7 @@  (define-public python-numpy-groupies
 (define-public python-pyvista
   (package
     (name "python-pyvista")
-    (version "0.36.1")
+    (version "0.39.1")
     (source
      ;; The PyPI tarball does not contain the tests.
      ;; (However, we don't yet actually run the tests.)
@@ -1352,15 +1352,15 @@  (define-public python-pyvista
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1kjilcrz2cyh67n79r8dpxrans99mlviz2whc6g7j8hgn7v14z2n"))))
+        (base32 "00nij00z5r35f6dx7mwndsrpmiw43adjk8x35mk308c369ylbv9p"))))
     (build-system python-build-system)
     (propagated-inputs
-     (list python-appdirs
-           python-imageio
+     (list python-imageio
            python-matplotlib
            python-meshio
            python-numpy
            python-pillow
+           python-pooch
            python-scooby
            vtk))
     (arguments
@@ -1371,7 +1371,7 @@  (define-public python-pyvista
          (delete 'check)
          ;; Disable the sanity check, which fails with the following error:
          ;;
-         ;;   ...checking requirements: ERROR: pyvista==0.34.0 DistributionNotFound(Requirement.parse('vtk'), {'pyvista'})
+         ;;   ...checking requirements: ERROR: pyvista==0.39.1 DistributionNotFound(Requirement.parse('vtk'), {'pyvista'})
          (delete 'sanity-check))))
     (home-page "https://docs.pyvista.org/")
     (synopsis "3D plotting and mesh analysis through VTK")