diff mbox series

[bug#74355,v2,6/7] gnu: Add go-github-com-zeebo-blake3.

Message ID 85e4366a8c7d45cdec68f147b9cedbb91d9f492f.1731741895.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#74355,v2,1/7] gnu: Add go-github-com-caddyserver-zerossl. | expand

Commit Message

Artyom V. Poptsov Nov. 16, 2024, 7:26 a.m. UTC
* gnu/packages/golang-crypto.scm (go-github-com-zeebo-blake3): New variable.

Change-Id: I23bc863fb1731b520aeca8e9088a98c6fcfcf62d
---
 gnu/packages/golang-crypto.scm | 38 ++++++++++++++++++++++++++++++----
 1 file changed, 34 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index d5915bc64d..0f0e32b82a 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1727,6 +1727,35 @@  (define-public go-github-com-youmark-pkcs8
 PKCS#5 (v2.0) algorithms.")
     (license license:expat)))
 
+(define-public go-github-com-zeebo-blake3
+  (package
+    (name "go-github-com-zeebo-blake3")
+    (version "0.2.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/zeebo/blake3")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "117p973ccgalaqg7byj0qcd1xapysplql9np1sr9jkca500khcgf"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/zeebo/blake3"))
+    (propagated-inputs
+     (list go-github-com-klauspost-cpuid-v2
+           go-github-com-zeebo-assert
+           go-github-com-zeebo-pcg))
+    (home-page "https://github.com/zeebo/blake3")
+    (synopsis "Pure Go implementation of BLAKE3")
+    (description
+     "@code{blake3} is a pure Go implementation of
+@url{https://en.wikipedia.org/wiki/BLAKE_(hash_function)#BLAKE3, BLAKE3} with AVX2
+and SSE4.1 acceleration.")
+    (license license:cc0)))
+
 (define-public go-github-com-zeebo-pcg
   (package
     (name "go-github-com-zeebo-pcg")
@@ -1774,10 +1803,11 @@  (define-public go-lukechampine-com-blake3
      (list go-github-com-klauspost-cpuid))
     (home-page "https://pkg.go.dev/lukechampine.com/blake3")
     (synopsis "Implementation of the BLAKE3 cryptographic hash function")
-    (description "@code{blake3} implements the BLAKE3 cryptographic hash
-function.  In addition to the pure-Go implementation, this package also
-contains AVX-512 and AVX2 routines (generated by avo) that greatly increase
-performance for large inputs and outputs.")
+    (description
+     "@code{blake3} implements the BLAKE3 cryptographic hash function.  In addition
+to the pure-Go implementation, this package also contains AVX-512 and AVX2
+routines (generated by avo) that greatly increase performance for large inputs and
+outputs.")
     (license license:expat)))
 
 (define-public go-torproject-org-pluggable-transports-goptlib