[bug#76862,1/6] gnu: Add argparse.

Message ID 85a74ab01b644070fe8b38cb429cbc387274b6fa.1741431068.git.iyzsong@member.fsf.org
State New
Headers
Series Add tic80 |

Commit Message

King, Spencer via Guix-patches" via March 8, 2025, 10:55 a.m. UTC
  From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/c.scm (argparse): New variable.

Change-Id: I846cf9229c44f6e40b07dc9f82cd0327ebd02fcb
---
 gnu/packages/c.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
  

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index bd5f8ac20f..8efb782811 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1020,6 +1020,39 @@  (define-public byacc
 C programming language.")
     (license license:public-domain)))
 
+(define-public argparse
+  (package
+    (name "argparse")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/cofyc/argparse")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0zb0b2aikk4dasjzsyiyf2xn1hbld8gf8np3843zcg9wbxydd8zd"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:test-target "test"
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)      ;no configure script
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out"))
+                          (inc (string-append out "/include"))
+                          (lib (string-append out "/lib")))
+                     (install-file "argparse.h" inc)
+                     (install-file "libargparse.so" lib)))))))
+    (synopsis "Command line arguments parsing library")
+    (home-page "https://github.com/cofyc/argparse")
+    (description
+     "This C library provides high-level arguments parsing solutions inspired
+by Python's @code{argparse} module.")
+    (license license:expat)))
+
 (define-public aws-c-common
   (package
     (name "aws-c-common")