diff mbox series

[bug#73558,2/4] gnu: gsl: Build with ‘-O2 -g’ unconditionally.

Message ID 85a2d861d815ffee24f109c2c5fe2cdba64e23ca.1727642162.git.ludo@gnu.org
State New
Headers show
Series [bug#73558,1/4] gnu: gsl: Add debug output. | expand

Commit Message

Ludovic Courtès Sept. 29, 2024, 8:36 p.m. UTC
Fixes a regression introduced in
53bec65c51c3f2b7e318db4dc7a5c3a09ad00214 that would cause gsl to be
built without optimizations and without debugging symbols (equivalent to
“-O0 -g0”).

* gnu/packages/maths.scm (gsl)[arguments]: Remove #:make-flags.

Change-Id: I5297e3602bffbb7655d655622cc3d7595f82b25a
---
 gnu/packages/maths.scm | 12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9032b5268a..d318dc3d0b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -728,17 +728,7 @@  (define-public gsl
     (outputs '("out" "static" "debug"))
     (build-system gnu-build-system)
     (arguments
-     (list ;; FIXME: Setting CFLAGS=-fPIC is not only unnecessary, it's also
-           ;; harmful because it removes the default '-O2 -g', meaning that the
-           ;; library ends up being compiled as -O0.  Consequently, some
-           ;; numerical tests fail, notably on i686-linux.  TODO: Remove
-           ;; 'CFLAGS=-fPIC' for all systems and revisit or remove
-           ;; 'disable-failing-tests' phases accordingly.
-           #:make-flags (if (and (not (%current-target-system))
-                                 (string=? (%current-system) "i686-linux"))
-                            #~'()
-                            #~(list "CFLAGS=-fPIC"))
-           #:phases
+     (list #:phases
            #~(modify-phases %standard-phases
                #$@(cond
                    ((and (target-riscv64?)