diff mbox series

[bug#64905,v5,01/10] gnu: tree-sitter: Update to 0.20.10.

Message ID 85953639236a1c4ebe66dac6d4ecd71544083f5e.1697729704.git.hako@ultrarare.space
State New
Headers show
Series [bug#64905,v5,01/10] gnu: tree-sitter: Update to 0.20.10. | expand

Commit Message

Hilton Chain Oct. 19, 2023, 3:44 p.m. UTC
* gnu/packages/tree-sitter.scm (tree-sitter): Update to 0.20.10.
(tree-sitter-cli)[arguments]<#:cargo-test-flags>: Skip github_issue_test.
<#:cargo-inputs>: Add rust-path-slash-0.2.
---
 gnu/packages/tree-sitter.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 009f2edeef..12cc880b29 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -98,16 +98,16 @@  (define-public python-tree-sitter
 (define-public tree-sitter
   (package
     (name "tree-sitter")
-    (version "0.20.8")
+    (version "0.20.10")                 ;untagged
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/tree-sitter/tree-sitter")
-                    (commit (string-append "v" version))))
+                    (commit "0e4ff0bb27edf37b76fc7d35aa768b02cf4392ad")))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "10w17lfn9asqrk612xivkx26lc620s3nnm30hhlyqd4bj19k7gyv"))
+                "1bai4gdhf8w5p1i9np2kl2ms0jq6rgq98qpiipipzayb9jjjlxcy"))
               (modules '((guix build utils)))
               (snippet #~(begin
                            ;; Remove bundled ICU parts
@@ -175,6 +175,7 @@  (define-public tree-sitter-cli
          ;; good compromise compared to maintaining two different sets of
          ;; grammars (Guix packages vs test fixtures).
          "--skip=tests::corpus_test"
+         "--skip=tests::github_issue_test"
          "--skip=tests::highlight_test"
          "--skip=tests::node_test"
          "--skip=tests::parser_test"
@@ -196,6 +197,7 @@  (define-public tree-sitter-cli
         ("rust-dirs" ,rust-dirs-3)
         ("rust-html-escape" ,rust-html-escape-0.2)
         ("rust-libloading" ,rust-libloading-0.7)
+        ("rust-path-slash" ,rust-path-slash-0.2)
         ("rust-rand" ,rust-rand-0.8)
         ("rust-rustc-hash" ,rust-rustc-hash-1)
         ("rust-semver" ,rust-semver-1)