diff mbox series

[bug#50002] gnu: Add ocaml-odoc-parser.

Message ID 8576738711035131526e9d09163fba20119d9110.1628677077.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#50002] gnu: Add ocaml-odoc-parser. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Aug. 11, 2021, 10:18 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-odoc-parser): New variable.
---
 gnu/packages/ocaml.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 2730ed9a0e905c4d8b9303f1454620a648822b21

Comments

Ludovic Courtès Aug. 30, 2021, 12:51 p.m. UTC | #1
Hi,

Xinglu Chen <public@yoctocell.xyz> skribis:

> * gnu/packages/ocaml.scm (ocaml-odoc-parser): New variable.

Pushed, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 112751ddec..6ef0823738 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6606,6 +6606,34 @@  advantage over ocamldoc is an accurate cross-referencer, which handles the
 complexity of the OCaml module system.")
     (license license:isc)))
 
+(define-public ocaml-odoc-parser
+  (package
+    (name "ocaml-odoc-parser")
+    (version "0.9.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/ocaml-doc/odoc-parser")
+              (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+           "1jlc6dp3v90r1ra7r0jfw0xs8rylwdz9gymw4rd53h0p17cw1wnj"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+      `(("ocaml-astring" ,ocaml-astring)
+        ("ocaml-result" ,ocaml-result)))
+    (native-inputs
+      `(("ocaml-ppx-expect" ,ocaml-ppx-expect)))
+    (home-page "https://github.com/ocaml-doc/odoc-parser")
+    (synopsis "Parser for ocaml documentation comments")
+    (description
+     "This package provides a library for parsing the contents of OCaml
+documentation comments, formatted using Odoc syntax, an extension of the
+language understood by ocamldoc.")
+    (license license:isc)))
+
 ;; version 1.5.2 requires ocaml-markdown 1.0.0 which does not compile
 ;; with old version of dune used in package-with-ocaml4.07
 (define-public ocaml4.07-odoc