diff mbox series

[bug#54419] gnu: Add python-scikit-allel.

Message ID 856daf639aa2f6dee3f09e242179ba2fccaf22d8.1647430620.git.efraim@flashner.co.il
State Accepted
Headers show
Series [bug#54419] gnu: Add python-scikit-allel. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner March 16, 2022, 11:37 a.m. UTC
* gnu/packages/python-science.scm (python-scikit-allel): New variable.
---
 gnu/packages/python-science.scm | 51 ++++++++++++++++++++++++++++++++-
 1 file changed, 50 insertions(+), 1 deletion(-)


base-commit: 53d986215f629f461651e3181af0689ef5f418a2

Comments

Ludovic Courtès March 18, 2022, 1:57 p.m. UTC | #1
Hello,

Efraim Flashner <efraim@flashner.co.il> skribis:

> * gnu/packages/python-science.scm (python-scikit-allel): New variable.

LGTM!

Ludo’.
Efraim Flashner March 18, 2022, 2 p.m. UTC | #2
Thanks for the review. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index e3e874dac2..bb25386094 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -3,7 +3,7 @@ 
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016-2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -35,6 +35,7 @@  (define-module (gnu packages python-science)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bioinformatics)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cpp)
@@ -307,6 +308,54 @@  (define-public python-scikit-image
      "Scikit-image is a collection of algorithms for image processing.")
     (license license:bsd-3)))
 
+(define-public python-scikit-allel
+  (package
+    (name "python-scikit-allel")
+    (version "1.3.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "scikit-allel" version))
+        (sha256
+         (base32 "1vg88ng6gd175gzk39iz1drxig5l91dyx398w2kbw3w8036zv8gj"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+       #:phases
+       #~(modify-phases %standard-phases
+           (replace 'check
+             (lambda* (#:key tests? #:allow-other-keys)
+               (when tests?
+                 (invoke "python" "setup.py" "build_ext" "--inplace")
+                 (invoke "python" "-m" "pytest" "-v" "allel"
+                         ;; AttributeError: 'Dataset' object has no attribute 'asstr'
+                         "-k" (string-append
+                                "not test_vcf_to_hdf5"
+                                " and not test_vcf_to_hdf5_exclude"
+                                " and not test_vcf_to_hdf5_rename"
+                                " and not test_vcf_to_hdf5_group"
+                                " and not test_vcf_to_hdf5_ann"))))))))
+    (propagated-inputs
+     (list python-dask
+           python-numpy))
+    (native-inputs
+     (list python-cython
+           ;; The following are all needed for the tests
+           htslib
+           python-h5py
+           python-hmmlearn
+           python-numexpr
+           python-pytest
+           python-scipy
+           python-setuptools-scm
+           python-zarr))
+    (home-page "https://github.com/cggh/scikit-allel")
+    (synopsis "Explore and analyze genetic variation data")
+    (description
+     "This package provides utilities for exploratory analysis of large scale
+genetic variation data.")
+    (license license:expat)))
+
 (define-public python-sgp4
   (package
     (name "python-sgp4")