diff mbox series

[bug#72589] gnu: Add firebird-emu.

Message ID 856900d9-5995-cd04-bf8f-d08d8d64f461@disroot.org
State New
Headers show
Series [bug#72589] gnu: Add firebird-emu. | expand

Commit Message

Adam Faiz Aug. 12, 2024, 7:13 a.m. UTC
From 7055c1c7e9b7458d5c905a21c8efd4818425faf2 Mon Sep 17 00:00:00 2001
Message-ID: <7055c1c7e9b7458d5c905a21c8efd4818425faf2.1723445985.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 12 Aug 2024 14:50:40 +0800
Subject: [PATCH] gnu: Add firebird-emu.

* gnu/packages/maths.scm (firebird-emu): New variable.
---
 gnu/packages/maths.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)


base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8

Comments

Nicolas Graves Aug. 15, 2024, 10:44 p.m. UTC | #1
Hi Adam,

It seems that QA couldn't compile the revision but I can on my
side. Maybe you can resend the patch so that QA re-evaluates the patch?

Thanks,
Andreas Enge Sept. 22, 2024, 8:50 a.m. UTC | #2
Hello,

(adding the Qt team in CC)

I have tried to build the package, but get a hash mismatch:
  expected hash: 0q8j2prs7713drwdgxwi1dhzk4gp9d908bx6p15fh5x2ffb676v6
  actual hash:   1ws8y38gmcg63zmq67sx1px21d0ssncgy6bmkn26471fl1854adw
hash mismatch for store item '/gnu/store/q6k9hx61c940akz8arwbh4v84jl3slpc-firebird-emu-1.6-checkout'
build of /gnu/store/x8mb0b752vrjqc68hwp80rfjnw8nkn0v-firebird-emu-1.6-checkout.drv failed

The description says that the package does not ship a ROM image, but
I suppose it can be used without one?

It is a bit unfortunate to introduce a package relying on Qt5 while I think
we are slowly moving towards Qt6.

Is it necessary to propagate qtdeclarative-5 and qtquickcontrols-5,
or could this be handled differently?

Finally I am not sure whether the license is gpl3 or gpl3+.
I did not find license headers in the source code, but this statement in
README.md:
"This work (except the icons from the KDE project) is licensed under the GPLv3."
So I think it might to safer to interpret this as GPLv3 only.

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e3bb14a3c2..83015f5346 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -104,6 +104,7 @@  (define-module (gnu packages maths)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system ruby)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages audio)
@@ -9439,6 +9440,52 @@  (define-public qalculate-gtk
 interval arithmetic, plotting.")
     (license license:gpl2+)))
 
+(define-public firebird-emu
+  (package
+    (name "firebird-emu")
+    (version "1.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/nspire-emus/firebird")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0q8j2prs7713drwdgxwi1dhzk4gp9d908bx6p15fh5x2ffb676v6"))
+              (modules '((guix build utils)))
+              (snippet
+               #~(begin
+                   (substitute* "firebird.pro"
+                     (("core/gif-h/gif\\.h")
+                      "core/gif.h"))))))
+    (arguments
+     (list
+      #:tests? #f ; no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (replace 'build
+            (lambda _
+              (mkdir-p "build")
+              (chdir "build")
+              (invoke "qmake" (string-append "PREFIX=" #$output) "..")
+              (invoke "make"))))))
+    (build-system qt-build-system)
+    (inputs
+     (list qtbase-5
+           zlib))
+    (propagated-inputs
+     (list qtdeclarative-5 qtquickcontrols-5))
+    (synopsis "TI Nspire calculator emulator")
+    (description
+     "Firebird Emu is an emulator for the TI Nspire calculator series.
+It supports the emulation of Nspire Touchpad (CAS), CX (CAS)
+and CX II (-T/CAS) calculators.  Note that this package does @emph{not}
+provide the ROM images.")
+    (home-page "https://github.com/nspire-emus/firebird")
+    (license license:gpl3+)))
+
 (define-public numdiff
   (package
     (name "numdiff")