diff mbox series

[bug#36197] gnu: add celestia; celestia-gtk

Message ID 855zp9gxna.fsf@disroot.org
State Accepted
Headers show
Series [bug#36197] gnu: add celestia; celestia-gtk | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Amar M. Singh June 13, 2019, 6:15 p.m. UTC
Added Celestia; space visualisation and simulator to (gnu packages
astronomy).

Tests are disabled because the project does not include any tests.

Comments

swedebugia June 25, 2019, 7:25 p.m. UTC | #1
On 2019-06-13 20:15, Amar Singh wrote:
> 
> Added Celestia; space visualisation and simulator to (gnu packages
> astronomy).
> 
> Tests are disabled because the project does not include any tests.

 > +      (license license:gpl2))))

Source code files say 2 or later. Otherwise LGTM.

I'm not going to review the celestia-gtk because of small bandwidth.

Thanks for the patch!
Eric Bavier July 2, 2019, 2:54 p.m. UTC | #2
Did this patch address the concerns raised in this thread: https://lists.gnu.org/archive/html/guix-devel/2015-07/msg00030.html ?
Ludovic Courtès July 4, 2019, 8:02 a.m. UTC | #3
Hi Eric,

Eric Bavier <ericbavier@centurylink.net> skribis:

> Did this patch address the concerns raised in this thread: https://lists.gnu.org/archive/html/guix-devel/2015-07/msg00030.html ?

Good question, I don’t know.  Could you take a look?

I picked it up because there had been no comments for some time, but I
was unaware of the issues you raise.

Thanks for the heads-up,
Ludo’.
Sharlatan Hellseher March 29, 2024, 3:03 p.m. UTC | #4
Hi!

Celestia is on the latest version and periodically checked for
updates.

Closing this issue as no more relevant.

Thanks,
Oleg
diff mbox series

Patch

From c8dd3c6871da910761ea8908f6bc9866c7f3c5ac Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Thu, 13 Jun 2019 22:53:22 +0530
Subject: [PATCH 2/2] gnu: Add celestia-gtk.

* gnu/packages/astronomy.scm (celestia-gtk): New variable.
---
 gnu/packages/astronomy.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c0ddbca033..206b9b0b5a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -38,6 +38,8 @@ 
   #:use-module (gnu packages perl)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages maths)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu))
@@ -238,3 +240,18 @@  object in the expandable database and view it from any point in space and
 time.  The position and movement of solar system objects is calculated
 accurately in real time at any rate desired.")
       (license license:gpl2))))
+
+(define-public celestia-gtk
+  (package (inherit celestia)
+           (name "celestia-gtk")
+           (version (package-version celestia))
+           (inputs
+            (append (filter (lambda (x)
+                              (not (equal? (car x) "freeglut")))
+                            (package-inputs celestia))
+                    `(("gtk2" ,gtk+-2)
+                      ("gtkglext" ,gtkglext))))
+           (arguments
+            `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
+              #:tests? #f))))
+
-- 
2.22.0