diff mbox series

[bug#65779,2/2] gnu: uncrustify: use new style and gexp.

Message ID 8553c0cf1b76028589f8cde270af18e295b3f8a6.1693997256.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series uncrustify: Update to 0.77.1. | expand

Commit Message

Z572 Sept. 6, 2023, 10:51 a.m. UTC
* gnu/packages/code.scm (uncrustify): use new style and gexp.
[native-inputs]: remove label.
[arguments]: use gexp and remove tail #t.
---
 gnu/packages/code.scm | 24 +++++++++++-------------
 1 file changed, 11 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 1bc6cd541e..b2b36a2d6f 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -798,20 +798,18 @@  (define-public uncrustify
                (base32
                 "17x9p5pqgzjchi9xhskp4kq7ag4chmsgbkvwym5m2b9zwm6qykpm"))))
     (build-system cmake-build-system)
-    (native-inputs
-     `(("python" ,python-wrapper)))
+    (native-inputs (list python-wrapper))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'unpack-etc
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; Configuration samples are not installed by default.
-             (let* ((output (assoc-ref outputs "out"))
-                    (etcdir (string-append output "/etc")))
-               (for-each (lambda (l)
-                           (install-file l etcdir))
-                         (find-files "etc" "\\.cfg$")))
-             #t)))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'unpack-etc
+                 (lambda* (#:key inputs outputs #:allow-other-keys)
+                   ;; Configuration samples are not installed by default.
+                   (let* ((output (assoc-ref outputs "out"))
+                          (etcdir (string-append output "/etc")))
+                     (for-each (lambda (l)
+                                 (install-file l etcdir))
+                               (find-files "etc" "\\.cfg$"))))))))
     (home-page "https://uncrustify.sourceforge.net/")
     (synopsis "Code formatter for C and other related languages")
     (description