diff mbox series

[bug#68890,v2] gnu: pspp: Update to 2.0.0

Message ID 85490b486948461bf2c14003c23602bf0f95bdc5.1708851816.git.atai@atai.org
State New
Headers show
Series [bug#68890,v2] gnu: pspp: Update to 2.0.0 | expand

Commit Message

Andy Tai Feb. 25, 2024, 9:04 a.m. UTC
* gnu/packages/statistics.scm (pspp): Update to 2.0.0
  [arguments](phases): Patch test case to skip failed test due to locale

Change-Id: I9feeab72789347033d2df8f23bda9ea27aaa7dd9
---
 gnu/packages/statistics.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)


base-commit: 05bbe9993f687da1fd684a31474c621f2a1c37b2

Comments

Nicolas Goaziou Feb. 25, 2024, 3:06 p.m. UTC | #1
Hello,

Andy Tai <atai@atai.org> writes:

> * gnu/packages/statistics.scm (pspp): Update to 2.0.0
>   [arguments](phases): Patch test case to skip failed test due to locale
>
> Change-Id: I9feeab72789347033d2df8f23bda9ea27aaa7dd9
> ---
>  gnu/packages/statistics.scm | 14 ++++++++++----
>  1 file changed, 10 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
> index 01d5e25a1a..b77f167c03 100644
> --- a/gnu/packages/statistics.scm
> +++ b/gnu/packages/statistics.scm
> @@ -115,7 +115,7 @@ (define-module (gnu packages statistics)
>  (define-public pspp
>    (package
>      (name "pspp")
> -    (version "1.4.1")
> +    (version "2.0.0")
>      (source
>       (origin
>        (method url-fetch)
> @@ -123,12 +123,18 @@ (define-public pspp
>                            version ".tar.gz"))
>        (sha256
>         (base32
> -        "0lqrash677b09zxdlxp89z6k02y4i23mbqg83956dwl69wc53dan"))))
> +        "1pyqlab9kw65wxc8pilcwb64l18w37xxdg3r6n287c7mda4cpxm8"))))
>      (build-system gnu-build-system)
>      (arguments
>       (list #:phases
>             #~(modify-phases %standard-phases
> -               (add-before 'check 'prepare-tests
> +         (add-after 'unpack 'patch-test-suite
> +				 (lambda _
> +				   (substitute* "tests/output/tex.at"
> +					   (("AT_CHECK\\(\\[LC_ALL=C.UTF-8 pspp")
> +						   "dnl AT_CHECK([LC_ALL=C.UTF-8 pspp"))
> +					 #t))

Nitpick: trailing #T are no longer recommended at the end of phases. You
can remove this one.

> +         (add-before 'check 'prepare-tests
>                   ;; Prevent irrelevant errors that cause test output mismatches:
>                   ;; ‘Fontconfig error: No writable cache directories’
>                   (lambda _
> @@ -149,7 +155,7 @@ (define-public pspp
>             `(,glib "bin") ;for glib-genmarshal
>             perl
>             pkg-config
> -           python-2 ;for tests
> +           python-3 ;for tests

This change should appear in the commit message.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 01d5e25a1a..b77f167c03 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -115,7 +115,7 @@  (define-module (gnu packages statistics)
 (define-public pspp
   (package
     (name "pspp")
-    (version "1.4.1")
+    (version "2.0.0")
     (source
      (origin
       (method url-fetch)
@@ -123,12 +123,18 @@  (define-public pspp
                           version ".tar.gz"))
       (sha256
        (base32
-        "0lqrash677b09zxdlxp89z6k02y4i23mbqg83956dwl69wc53dan"))))
+        "1pyqlab9kw65wxc8pilcwb64l18w37xxdg3r6n287c7mda4cpxm8"))))
     (build-system gnu-build-system)
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
-               (add-before 'check 'prepare-tests
+         (add-after 'unpack 'patch-test-suite
+				 (lambda _
+				   (substitute* "tests/output/tex.at"
+					   (("AT_CHECK\\(\\[LC_ALL=C.UTF-8 pspp")
+						   "dnl AT_CHECK([LC_ALL=C.UTF-8 pspp"))
+					 #t))
+         (add-before 'check 'prepare-tests
                  ;; Prevent irrelevant errors that cause test output mismatches:
                  ;; ‘Fontconfig error: No writable cache directories’
                  (lambda _
@@ -149,7 +155,7 @@  (define-public pspp
            `(,glib "bin") ;for glib-genmarshal
            perl
            pkg-config
-           python-2 ;for tests
+           python-3 ;for tests
            texinfo))
     (home-page "https://www.gnu.org/software/pspp/")
     (synopsis "Statistical analysis")