diff mbox series

[bug#41919] Add curlpp C++ bindings to curl package

Message ID 8505866a62c4f727a4bfb34e5e3ee76bc2aeabe2.camel@rdmp.org
State Accepted
Headers show
Series [bug#41919] Add curlpp C++ bindings to curl package | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Dale Mellor June 28, 2020, 9:43 p.m. UTC
On Wed, 2020-06-24 at 20:58 +0200, Marius Bakke wrote:
> Hello Dale,
> 
> Thanks for the updated patch.  I will suggest another few improvements,
> then I think it should be good to go.  :-)


  All suggestions taken on board.

Thank you for checking over it,
Dale

Comments

Ludovic Courtès July 3, 2020, 9:48 p.m. UTC | #1
Hi Dale,

Dale Mellor <guix-devel-0brg6b@rdmp.org> skribis:

> From 16bff1a7c18ead5bb923f2b75e38371718660abb Mon Sep 17 00:00:00 2001
> From: Dale Mellor <guix-devel-0brg6b@rdmp.org>
> Date: Sun, 21 Jun 2020 23:53:07 +0100
> Subject: [PATCH] gnu: Add curlpp library.
>
> * gnu/packages/curl.scm (curlpp): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 16bff1a7c18ead5bb923f2b75e38371718660abb Mon Sep 17 00:00:00 2001
From: Dale Mellor <guix-devel-0brg6b@rdmp.org>
Date: Sun, 21 Jun 2020 23:53:07 +0100
Subject: [PATCH] gnu: Add curlpp library.

* gnu/packages/curl.scm (curlpp): New variable.
---
 gnu/packages/curl.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 48d7dd40bd..86fd9a8c10 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Dale Mellor <guix-devel-0brg6b@rdmp.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,6 +33,7 @@ 
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix utils)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (gnu packages)
@@ -258,3 +260,34 @@  not offer a replacement for libcurl.")
 Guile to do client-side URL transfers, like requesting documents from HTTP or
 FTP servers.  It is based on the curl library.")
    (license license:gpl3+)))
+
+(define-public curlpp
+  (package
+    (name "curlpp")
+    (version "0.8.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jpbarrette/curlpp.git")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1b0ylnnrhdax4kwjq64r1fk0i24n5ss6zfzf4hxwgslny01xiwrk"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    ;; There are no build tests to be had.
+    (arguments
+     '(#:tests? #f))
+    ;; The installed version needs the header files from the C library.
+    (propagated-inputs
+     `(("curl" ,curl)))
+    (synopsis "C++ wrapper around libcURL")
+    (description
+     "This package provides a free and easy-to-use client-side C++ URL
+transfer library, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT,
+FILE and LDAP; in particular it supports HTTPS certificates, HTTP POST, HTTP
+PUT, FTP uploading, kerberos, HTTP form based upload, proxies, cookies,
+user+password authentication, file transfer resume, http proxy tunneling and
+more!")
+    (home-page "http://www.curlpp.org")
+    (license license:expat)))
-- 
2.26.2