[bug#77956,gnome-team,13/23] gnu: gstreamer: Update to 1.26.0.

Message ID 8503d04dc4ecab75335e1b81fb2a6e819ac1894c.1745243273.git.liliana.prikler@gmail.com
State New
Headers
Series Start working on GNOME 48 |

Commit Message

Liliana Marie Prikler April 21, 2025, 1:47 p.m. UTC
  * gnu/packages/gstreamer.scm (gstreamer): Update to 1.26.0.
---
 gnu/packages/gstreamer.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
  

Comments

Maxim Cournoyer April 23, 2025, 1:54 a.m. UTC | #1
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gstreamer.scm (gstreamer): Update to 1.26.0.
> ---
>  gnu/packages/gstreamer.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
> index b93e84dba45..d4a2d66980d 100644
> --- a/gnu/packages/gstreamer.scm
> +++ b/gnu/packages/gstreamer.scm
> @@ -466,7 +466,7 @@ (define %common-gstreamer-phases
>  (define-public gstreamer
>    (package
>      (name "gstreamer")
> -    (version "1.24.9")
> +    (version "1.26.0")

Typically when I update gstreamer I update all that is in (gnu packages
gstreamer) at the same time (can be done with 'guix refresh -u -s
module:gstreamer'), to minimize the chances of breakage.
  
Liliana Marie Prikler April 23, 2025, 4:14 a.m. UTC | #2
Am Mittwoch, dem 23.04.2025 um 10:54 +0900 schrieb Maxim Cournoyer:
> Typically when I update gstreamer I update all that is in (gnu
> packages gstreamer) at the same time (can be done with 'guix refresh
> -u -s module:gstreamer'), to minimize the chances of breakage.
While I did not use that exact command, I still effectively updated all
the gst- things.  Am I missing something?

Cheers
  
Maxim Cournoyer April 24, 2025, 12:17 a.m. UTC | #3
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Mittwoch, dem 23.04.2025 um 10:54 +0900 schrieb Maxim Cournoyer:
>> Typically when I update gstreamer I update all that is in (gnu
>> packages gstreamer) at the same time (can be done with 'guix refresh
>> -u -s module:gstreamer'), to minimize the chances of breakage.
> While I did not use that exact command, I still effectively updated all
> the gst- things.  Am I missing something?

I think the gstreamer module might have packages not prefixed with gst-,
but closely related nontheless, so it's good to update the whole module,
while at it (it's usually straightforward to do so in my experience).
  

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index b93e84dba45..d4a2d66980d 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -466,7 +466,7 @@  (define %common-gstreamer-phases
 (define-public gstreamer
   (package
     (name "gstreamer")
-    (version "1.24.9")
+    (version "1.26.0")
     (source
      (origin
        (method url-fetch)
@@ -475,7 +475,7 @@  (define-public gstreamer
              version ".tar.xz"))
        (sha256
         (base32
-         "03r6rwmih3nqxrfw9nkhpbwpwp1yf7qw3m2phl6a027mxrmppx7b"))))
+         "17r7zz6sn529dx0pwhdrc0dqdqg3qybc79zzdrvmphhhh01f8bhv"))))
     (build-system meson-build-system)
     (arguments
      (list #:disallowed-references (list python)