diff mbox series

[bug#47042] gnu: qtsolutions: Enable examples.

Message ID 84ac6377-e05b-9bac-39b0-24c35fae89cf@raghavgururajan.name
State Accepted
Headers show
Series [bug#47042] gnu: qtsolutions: Enable examples. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan March 10, 2021, 11:09 a.m. UTC
Hi Leo!

Currently with this patch, we have following issues:

[1] When examples are enabled for QtSingleApplication, it doesn't get 
linked to QtLockFile. (Try building without `;; Disable building of 
examples for QtSingleApplication.` block)

[2] For installation of examples, the binaries get installed in sub-dirs 
as `/bin/foo` instead of `/bin`.

Any ideas?

Regards,
RG.

Comments

Leo Prikler March 10, 2021, 12:58 p.m. UTC | #1
Am Mittwoch, den 10.03.2021, 06:09 -0500 schrieb Raghav Gururajan:
> Hi Leo!
> 
> Currently with this patch, we have following issues:
> 
> [1] When examples are enabled for QtSingleApplication, it doesn't
> get 
> linked to QtLockFile. (Try building without `;; Disable building of 
> examples for QtSingleApplication.` block)
Then I guess we have to rewrite that Makefile (or pseudo-Makefile) in
the snippet as well? 

> [2] For installation of examples, the binaries get installed in sub-
> dirs 
> as `/bin/foo` instead of `/bin`.
I don't think the compiled examples need to be installed at all –
rather their source code etc. should be installed to share/doc (in a
qtsolutions subfolder of course).  The act of compiling them is merely
a check, that they (plus the code they are an example of) "work as
intended" or at least compile as intended.

If I read your patch correctly, I made an indentation mistake during
the review process, is that correct?

Regards,
Leo
Raghav Gururajan March 10, 2021, 2:49 p.m. UTC | #2
Hi Leo!

> Then I guess we have to rewrite that Makefile (or pseudo-Makefile) in
> the snippet as well?
> 
> I don't think the compiled examples need to be installed at all –
> rather their source code etc. should be installed to share/doc (in a
> qtsolutions subfolder of course).  The act of compiling them is merely
> a check, that they (plus the code they are an example of) "work as
> intended" or at least compile as intended.

Never mind this patch then. I started working on this, thinking that 
example binaries might be useful. So I'll close this report.

Regards,
RG.
diff mbox series

Patch

From a1507241c457b9ee3d1474b71849112637a3c6a2 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Wed, 10 Mar 2021 03:09:38 -0500
Subject: [PATCH] gnu: qtsolutions: Enable examples.

* gnu/packages/qt.scm (qtsolutions) [arguments]: Modify phases
'patch-source and 'install.
---
 gnu/packages/qt.scm | 62 ++++++++++++++++++++++++++++++++-------------
 1 file changed, 44 insertions(+), 18 deletions(-)

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d921aa87fe..8409fc1803 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2497,18 +2497,18 @@  securely.  It will not store any data unencrypted unless explicitly requested.")
              (with-directory-excursion "qtsingleapplication/src"
                (for-each delete-file
                          (find-files "." "qtlockedfile.*\\.(h|cpp)"))
-                 (substitute* "qtsingleapplication.pri"
-                   ;; Add include path of LockedFile.
-                   (("INCLUDEPATH \\+=")
-                    "INCLUDEPATH += ../../qtlockedfile/src")
-                   ;; Link library of LockedFile.
-                   (("LIBS \\+=")
-                    "LIBS += -lQtSolutions_LockedFile"))
-                 (substitute* '("qtlocalpeer.h" "qtlocalpeer.cpp")
-                   (("#include \"qtlockedfile.*\\.cpp\"") "")
-                   ;; Unwrap namespace added in the vendoring process.
-                   (("QtLP_Private::QtLockedFile")
-                    "QtLockedFile")))
+               (substitute* "qtsingleapplication.pri"
+                 ;; Add include path of LockedFile.
+                 (("INCLUDEPATH \\+=")
+                  "INCLUDEPATH += ../../qtlockedfile/src")
+                 ;; Link library of LockedFile.
+                 (("LIBS \\+=")
+                  "LIBS += -lQtSolutions_LockedFile"))
+               (substitute* '("qtlocalpeer.h" "qtlocalpeer.cpp")
+                 (("#include \"qtlockedfile.*\\.cpp\"") "")
+                 ;; Unwrap namespace added in the vendoring process.
+                 (("QtLP_Private::QtLockedFile")
+                  "QtLockedFile")))
              #t))))
       (build-system gnu-build-system)
       (arguments
@@ -2524,16 +2524,32 @@  securely.  It will not store any data unencrypted unless explicitly requested.")
          (modify-phases %standard-phases
            (add-after 'unpack 'patch-source
              (lambda* (#:key outputs #:allow-other-keys)
+               ;; Rename example to examples, in qtlockedfile,
+               ;; so that it gets picked up during install phase.
+               (with-directory-excursion "qtlockedfile"
+                 (rename-file "example" "examples")
+                 (rename-file "examples/example.pro" "examples/examples.pro")
+                 (substitute* "qtlockedfile.pro"
+                   (("SUBDIRS\\+=example") "SUBDIRS+=examples")))
                (substitute* (find-files "." "common.pri")
+                 ;; Patch run-path for binaries.
+                 (("QMAKE_RPATHDIR \\+= \\$\\$?.*_LIBDIR")
+                  (string-append "QMAKE_RPATHDIR += "
+                                 (assoc-ref outputs "out") "/lib"))
                  ;; Remove unnecessary prefixes/suffixes in library names.
                  (("qt5") "qt")
                  (("-head") ""))
-               ;; Disable building of examples.
-               (substitute* (find-files "." "\\.pro$")
+               ;; Disable building of examples for QtSingleApplication.
+               (substitute* "qtsingleapplication/qtsingleapplication.pro"
                  (("SUBDIRS\\+=examples") ""))
-               ;; Fix deprecated functions.
-               (substitute* "qtsoap/src/qtsoap.cpp"
-                 (("toAscii") "toUtf8"))
+               (with-directory-excursion "qtsoap/src"
+                 ;; Patch Qt imports for QtSoap.
+                 (substitute* "qtsoap.pri"
+                   (("QT \\+= xml network")
+                    "QT += core gui widgets xml network"))
+                 ;; Fix deprecated functions.
+                 (substitute* "qtsoap.cpp"
+                   (("toAscii") "toUtf8")))
                #t))
            (replace 'configure
              (lambda _
@@ -2560,7 +2576,17 @@  securely.  It will not store any data unencrypted unless explicitly requested.")
                               (assoc-ref copy:%standard-phases 'install)
                               #:install-plan
                               '(("src" "include" #:include-regexp ("\\.h$"))
-                                ("lib" "lib"))
+                                ("lib" "lib")
+                                ("examples" "bin"
+                                 #:include ("examples" "canvas_typed"
+                                            "canvas_variant" "decoration"
+                                            "demo" "extension"
+                                            "object_controller" "simple"
+                                            "controller" "interactive"
+                                            "httpservice" "console"
+                                            "loader" "trivial"
+                                            "easter" "google"
+                                            "population")))
                               args)))
                          '("qtlockedfile" "qtpropertybrowser" "qtservice"
                            "qtsingleapplication" "qtsoap")))))))
-- 
2.30.1