diff mbox series

[bug#53930] gnu: Add emacs-nyan-mode.

Message ID 84aaa5ac2f6e4399fae554b274742c776c26fccf.camel@gmail.com
State Accepted
Headers show
Series [bug#53930] gnu: Add emacs-nyan-mode. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Liliana Marie Prikler Feb. 10, 2022, 8:56 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-nyan-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou Feb. 10, 2022, 10:58 p.m. UTC | #1
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-nyan-mode): New variable.

And I thought Guix was a serious distribution… ;)

> +(define-public emacs-nyan-mode
> +  (package
> +    (name "emacs-nyan-mode")
> +    (version "1.1.3")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://stable.melpa.org/packages/nyan-mode-"
> +             version
> +             ".tar"))

Using anything MELPA is generally frowned upon. What are the reasons for
not using upstream releases instead?

> +       (sha256
> +        (base32 "1hd3g1lnwsg7z3g9qvshlmlirgzyja4hjxxgdfpkaakafm87n58c"))))
> +    (build-system emacs-build-system)
> +    (arguments (list #:include #~(cons* "img/" "mus/" %default-include)))
> +    (home-page "https://github.com/TeMPOraL/nyan-mode/")
> +    (synopsis "Nyan Cat as position indicator")

Maybe: Nyan Cat as position indicator in a buffer

> +    (description
> +     "Nyan Mode is an analog indicator of your position in the buffer.  

I know the project name is "nyan mode" but still:

Nitpick: Nyan mode is…

Otherwise LGTM.

Regards,
Liliana Marie Prikler Feb. 11, 2022, 5:10 a.m. UTC | #2
Am Donnerstag, dem 10.02.2022 um 23:58 +0100 schrieb Nicolas Goaziou:
> Hello,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/emacs-xyz.scm (emacs-nyan-mode): New variable.
> 
> And I thought Guix was a serious distribution… ;)
How serious can Guix be if it lacks nyan-mode? 😺️

> > +(define-public emacs-nyan-mode
> > +  (package
> > +    (name "emacs-nyan-mode")
> > +    (version "1.1.3")
> > +    (source
> > +     (origin
> > +       (method url-fetch)
> > +       (uri (string-append
> > +             "https://stable.melpa.org/packages/nyan-mode-"
> > +             version
> > +             ".tar"))
> 
> Using anything MELPA is generally frowned upon. What are the reasons
> for not using upstream releases instead?
That's the code the importer gave me and I didn't know MELPA uses
autogenerated tarballs.  Will use git-fetch instead.

> > +       (sha256
> > +        (base32
> > "1hd3g1lnwsg7z3g9qvshlmlirgzyja4hjxxgdfpkaakafm87n58c"))))
> > +    (build-system emacs-build-system)
> > +    (arguments (list #:include #~(cons* "img/" "mus/" %default-
> > include)))
> > +    (home-page "https://github.com/TeMPOraL/nyan-mode/")
> > +    (synopsis "Nyan Cat as position indicator")
> 
> Maybe: Nyan Cat as position indicator in a buffer
Nyan Cat as a buffer position indicator?

> > +    (description
> > +     "Nyan Mode is an analog indicator of your position in the
> > buffer.  
> 
> I know the project name is "nyan mode" but still:
> 
> Nitpick: Nyan mode is…
I copied the title-case from the package preceding it.  WDYT about
"@code{nyan-mode} is", which would have been my goto before reading
that other description?

Cheers
Nicolas Goaziou Feb. 11, 2022, 9:19 a.m. UTC | #3
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Donnerstag, dem 10.02.2022 um 23:58 +0100 schrieb Nicolas Goaziou:

>> And I thought Guix was a serious distribution… ;)
> How serious can Guix be if it lacks nyan-mode? 😺️

So true.

>> Maybe: Nyan Cat as position indicator in a buffer
> Nyan Cat as a buffer position indicator?

Even better!

>> > +    (description
>> > +     "Nyan Mode is an analog indicator of your position in the
>> > buffer.  
>> 
>> I know the project name is "nyan mode" but still:
>> 
>> Nitpick: Nyan mode is…
> I copied the title-case from the package preceding it.  WDYT about
> "@code{nyan-mode} is", which would have been my goto before reading
> that other description?

I like Foo mode because all modes are spelled out like this (or
sometimes simply Foo) in the Emacs manual, as God intended.

As you pointed out, many packages just ignore this anyway. So, I'm fine
either way.

Regards,
Liliana Marie Prikler Feb. 11, 2022, 8:22 p.m. UTC | #4
Am Freitag, dem 11.02.2022 um 10:19 +0100 schrieb Nicolas Goaziou:
> > > And I thought Guix was a serious distribution… ;)
> > How serious can Guix be if it lacks nyan-mode? 😺️
> 
> So true.
High time we fix this.

> > > Maybe: Nyan Cat as position indicator in a buffer
> > Nyan Cat as a buffer position indicator?
> 
> Even better!
Done.

> > > > +    (description
> > > > +     "Nyan Mode is an analog indicator of your position in the
> > > > buffer.  
> > > 
> > > I know the project name is "nyan mode" but still:
> > > 
> > > Nitpick: Nyan mode is…
> > I copied the title-case from the package preceding it.  WDYT about
> > "@code{nyan-mode} is", which would have been my goto before reading
> > that other description?
> 
> I like Foo mode because all modes are spelled out like this (or
> sometimes simply Foo) in the Emacs manual, as God intended.
> 
> As you pointed out, many packages just ignore this anyway. So, I'm
> fine either way.
Pushed it the way God intended.  With "Nyan mode" and mplayer
hardcoded.

Cheers
Liliana Marie Prikler Feb. 11, 2022, 8:23 p.m. UTC | #5
Am Freitag, dem 11.02.2022 um 21:22 +0100 schrieb Liliana Marie
Prikler:
> Pushed it the way God intended.
Marking it done the way debbugs intends me to...
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 92c247ca38..f4101e88f0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5592,6 +5592,30 @@  (define-public emacs-mode-line-idle
 configuration.")
       (license license:gpl3+))))
 
+(define-public emacs-nyan-mode
+  (package
+    (name "emacs-nyan-mode")
+    (version "1.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://stable.melpa.org/packages/nyan-mode-"
+             version
+             ".tar"))
+       (sha256
+        (base32 "1hd3g1lnwsg7z3g9qvshlmlirgzyja4hjxxgdfpkaakafm87n58c"))))
+    (build-system emacs-build-system)
+    (arguments (list #:include #~(cons* "img/" "mus/" %default-include)))
+    (home-page "https://github.com/TeMPOraL/nyan-mode/")
+    (synopsis "Nyan Cat as position indicator")
+    (description
+     "Nyan Mode is an analog indicator of your position in the buffer.  The cat
+should go from left to right in your mode-line, as you move your point from 0%
+to 100%.  You can click on the rainbow or the empty space to scroll backwards
+and forwards and also animate it.")
+    (license license:gpl3+)))
+
 (define-public emacs-smart-mode-line
   (package
     (name "emacs-smart-mode-line")