diff mbox series

[bug#68555,v2,3/3] gnu: debootstrap: Add zstd dependency.

Message ID 849cb86147a238c990aaf9c341b09137492977eb.1706054193.git.GNUtoo@cyberdimension.org
State New
Headers show
Series [bug#68555,v2,1/3] gnu: Add trisquel-keyring. | expand

Commit Message

Denis 'GNUtoo' Carikli Jan. 24, 2024, midnight UTC
Without that fix, the following command:
    # debootstrap aramo aramo-root http://archive.trisquel.info/trisquel
fails with this error:
    I: Chosen extractor for .deb packages: dpkg-deb
    I: Extracting base-files...
    E: Tried to extract package, but tar failed. Exit...

And if we run the falling command manually:
    # sudo dpkg-deb --fsys-tarfile [...]/cache/apt/archives/base-files[...].deb
it shows that zstd is missing (from the PATH):
    dpkg-deb (subprocess): unable to execute decompressing archive
    'var/cache/apt/archives/base-files[...].deb' (size=60544) member
    'data.tar' (zstd): No such file or directory

* gnu/packages/debian.scm (debootstrap): [inputs]: Add zstd.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Change-Id: If24c80c70c9ec3e6ea88a38a30324fee3c0641fe
---
ChangeLog since V1: no changes.
---
 gnu/packages/debian.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 33c39e809e..1715b963a9 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -289,7 +289,9 @@  (define-public debootstrap
            bash-minimal
            dpkg
            tzdata
-
+           ;; Needed by dpkg-deb in extract_dpkg_deb_data for at least
+           ;; Trisquel 11 (aramo).
+           zstd
            ;; Called at run-time from various places, needs to be in PATH.
            gnupg
            wget))