diff mbox series

[bug#43768] gnu: zrythm: Update to 1.0.0-alpha.3.0.1.

Message ID 8491b0027fbe04b139ebac47ff5881ce00fafd27.camel@zrythm.org
State Accepted
Headers show
Series [bug#43768] gnu: zrythm: Update to 1.0.0-alpha.3.0.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Oct. 2, 2020, 5:29 p.m. UTC
Hi,

This patch updates Zrythm. I explicitly enabled rtmidi support (it was
implicitly enabled before), and also removed the xdg-open patch as it's
no longer necessary (the full path to xdg-open is now stored during
configuration).

Also, the versioning scheme changed to follow SemVer 2.0 (see
PACKAGING.md for details). I don't think there should be any problems
upgrading since the previous versions started with 0.

Thanks,
Alex

Comments

Mathieu Othacehe Oct. 6, 2020, 9:38 a.m. UTC | #1
Hello,

> This patch updates Zrythm. I explicitly enabled rtmidi support (it was
> implicitly enabled before), and also removed the xdg-open patch as it's
> no longer necessary (the full path to xdg-open is now stored during
> configuration).

Nice, applied thanks!

Mathieu
diff mbox series

Patch

From ba4a0bd67c226f291707911247148b8a28d8f11b Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 2 Oct 2020 18:19:00 +0100
Subject: [PATCH] gnu: zrythm: Update to 1.0.0-alpha.3.0.1.

* gnu/packages/music.scm (zrythm): Update to 1.0.0-alpha.3.0.1.
[arguments]: Explicitly enable RtMidi support in #:configure-flags.
<phases>: Remove xdg-open patch (no longer needed).
---
 gnu/packages/music.scm | 15 ++++-----------
 1 file changed, 4 insertions(+), 11 deletions(-)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1727bac7b8..97546a55e0 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5535,7 +5535,7 @@  and as an LV2 plugin.")
     ;; distros to make necessary changes to integrate the software into the
     ;; distribution.
     (name "zrythm")
-    (version "0.8.911")
+    (version "1.0.0-alpha.3.0.1")
     (source
       (origin
         (method url-fetch)
@@ -5543,7 +5543,7 @@  and as an LV2 plugin.")
                             version ".tar.xz"))
         (sha256
           (base32
-            "1xyp70sjc2k5pfdqbwqa988v86da0rmmyl8ry86bqv4ja80sc6g9"))))
+            "06025367x08y4g9grhcn35bk1dsrpgm04c8l8j50i3p49dl3s1n0"))))
    (build-system meson-build-system)
    (arguments
     `(#:glib-or-gtk? #t
@@ -5555,15 +5555,8 @@  and as an LV2 plugin.")
         "-Dgraphviz=enabled" ; for exporting routing graphs
         "-Dguile=enabled" ; for Guile scripting
         "-Djack=enabled" ; for JACK audio/MIDI backend
-        "-Dsdl=enabled") ; for SDL audio backend (which uses ALSA)
-      #:phases
-      (modify-phases %standard-phases
-        (add-after 'unpack 'patch-xdg-open
-          (lambda _
-            (substitute* "src/utils/io.c"
-                         (("OPEN_DIR_CMD")
-                          (string-append "\"" (which "xdg-open") "\"")))
-            #t)))))
+        "-Drtmidi=enabled" ; for RtMidi backend (ALSA sequencer)
+        "-Dsdl=enabled"))) ; for SDL audio backend (which uses ALSA)
    (inputs
     `(("alsa-lib" ,alsa-lib)
       ("jack" ,jack-1)
-- 
2.28.0