[bug#76686,emacs-team] gnu: emacs-ob-async: Skip tests.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-ob-async): Skip tests.
Change-Id: Idf66ac4106b4b5c0eb74c3e0a0b66a863e714295
---
gnu/packages/emacs-xyz.scm | 11 +++++++++++
1 file changed, 11 insertions(+)
base-commit: 5e1ae1d2041255cb0da37071482f2af86ed84ba3
@@ -10506,6 +10506,17 @@ (define-public emacs-ob-async
(sha256
(base32 "10x4hxrjm4pr6vg42a961h9ilqzyd0l0fv7fsbq9clxi439f1nd6"))))
(build-system emacs-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'remove-cask-from-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("cask exec ") "")))))
+ #:tests? #f ; 7 unexpected results out of 8
+ #:test-command '("make" "test")))
+ (native-inputs
+ (list which emacs-ert-runner))
(propagated-inputs
(list emacs-async emacs-dash))
(home-page "https://github.com/astahlman/ob-async")