diff mbox series

[bug#51358,1/4] gnu: Add ocaml-lacaml.

Message ID 842202eb6abc579a6d64b64ff41733a3536ff76b.1635011212.git.julien@lepiller.eu
State Accepted
Headers show
Series [bug#51358,1/4] gnu: Add ocaml-lacaml. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Julien Lepiller Oct. 23, 2021, 5:58 p.m. UTC
* gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
(ocaml-lacaml): ...this.  Use latest ocaml package.
---
 gnu/packages/ocaml.scm | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)

Comments

Simon Tournier Oct. 25, 2021, 1:56 p.m. UTC | #1
Hi Julien,

On sam., 23 oct. 2021 at 19:58, Julien Lepiller <julien@lepiller.eu> wrote:
> * gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
> (ocaml-lacaml): ...this.  Use latest ocaml package.
> ---
>  gnu/packages/ocaml.scm | 11 ++++-------
>  1 file changed, 4 insertions(+), 7 deletions(-)

Maybe I am missing something.  I fail to build it:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix build ocaml-lacaml --no-grafts

[...]

File "src/config/make_prec_dep.ml", line 1:
Error: /gnu/store/nly2n0llgm0x7hdr4x2xrm28v0qcadxf-ocaml4.07-base-0.11.1/lib/ocaml/site-lib/base/base.cmi
       is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
command "dune" "build" "@install" "--release" failed with status 1
builder for `/gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv' failed with exit code 1
build of /gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv failed
View build log at '/var/log/guix/drvs/1x/nqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv.bz2'.
guix build: error: build of `/gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv' failed
--8<---------------cut here---------------end--------------->8---


Cheers,
simon
Julien Lepiller Oct. 25, 2021, 10:05 p.m. UTC | #2
Le Mon, 25 Oct 2021 15:56:05 +0200,
zimoun <zimon.toutoune@gmail.com> a écrit :

> Hi Julien,
> 
> On sam., 23 oct. 2021 at 19:58, Julien Lepiller <julien@lepiller.eu>
> wrote:
> > * gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
> > (ocaml-lacaml): ...this.  Use latest ocaml package.
> > ---
> >  gnu/packages/ocaml.scm | 11 ++++-------
> >  1 file changed, 4 insertions(+), 7 deletions(-)  
> 
> Maybe I am missing something.  I fail to build it:
> 
> --8<---------------cut here---------------start------------->8---
> $ ./pre-inst-env guix build ocaml-lacaml --no-grafts
> 
> [...]
> 
> File "src/config/make_prec_dep.ml", line 1:
> Error:
> /gnu/store/nly2n0llgm0x7hdr4x2xrm28v0qcadxf-ocaml4.07-base-0.11.1/lib/ocaml/site-lib/base/base.cmi
> is not a compiled interface for this version of OCaml. It seems to be
> for an older version of OCaml. command "dune" "build" "@install"
> "--release" failed with status 1 builder for
> `/gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv'
> failed with exit code 1 build of
> /gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv
> failed View build log at
> '/var/log/guix/drvs/1x/nqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv.bz2'.
> guix build: error: build of
> `/gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv'
> failed --8<---------------cut
> here---------------end--------------->8---
> 
> 
> Cheers,
> simon

Ah, thanks for catching this. It looks like I went too fast when
submitting this series... My intention was to update in a separate
patch, but I only tested the updated version. My bad. Since I can't
build the new version with the old ocaml either, I'm updating in a
single patch.

I also noticed a mistake in the second patch, so I'll resend the series.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f640acca35..b128a4d19a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6757,7 +6757,7 @@  (define-public ocaml4.07-fftw3
        ("fftwf" ,fftwf)))
     (native-inputs
      `(("ocaml-cppo" ,(package-with-ocaml4.07 ocaml-cppo))
-       ("ocaml-lacaml" ,ocaml4.07-lacaml)))
+       ("ocaml-lacaml" ,(package-with-ocaml4.07 ocaml-lacaml))))
     (home-page
      "https://github.com/Chris00/fftw-ocaml")
     (synopsis
@@ -6767,9 +6767,9 @@  (define-public ocaml4.07-fftw3
 library FFTW.")
     (license license:lgpl2.1))) ; with static linking exception.
 
-(define-public ocaml4.07-lacaml
+(define-public ocaml-lacaml
   (package
-    (name "ocaml4.07-lacaml")
+    (name "ocaml-lacaml")
     (version "11.0.5")
     (source
      (origin
@@ -6783,10 +6783,7 @@  (define-public ocaml4.07-lacaml
          "180yb79a3qgx067qcpm50q12hrimjygf06rgkzbish9d1zfm670c"))))
     (build-system dune-build-system)
     (arguments
-     `(#:tests? #f ; No test target.
-       #:ocaml ,ocaml-4.07
-       #:findlib ,ocaml4.07-findlib
-       #:dune ,ocaml4.07-dune))
+     `(#:tests? #f)) ; No test target.
     (native-inputs
      `(("openblas" ,openblas)
        ("lapack" ,lapack)