[bug#74728] gnu: python-asyncssh: Disable flaky connection tests.

Message ID 8403c5159deb34bf4dac119d55c57c9dba530a20.1733594283.git.roman@burningswell.com
State New
Headers
Series [bug#74728] gnu: python-asyncssh: Disable flaky connection tests. |

Commit Message

Roman Scherer Dec. 7, 2024, 6 p.m. UTC
  * gnu/packages/ssh.scm (python-asyncssh): Disable flaky connection tests.

Change-Id: If99cc686679fd2c731f3d66a85abe23eff6f1234
---
 gnu/packages/ssh.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)


base-commit: bc630c5ebed27edd821ec363706f8b9cf1ee05cc
  

Comments

Sharlatan Hellseher Dec. 7, 2024, 10:40 p.m. UTC | #1
Hi,

Thanks for the patch.

Give it a try to refactor it by using pyproject-build-system,
contsing much simpler test excluding mechanics.

Oleg
  
Sharlatan Hellseher Dec. 8, 2024, 12:33 p.m. UTC | #2
Hi,

Pushed as f2ad73507b9a313024893e837aa11774f61b273f to master.

--
Thanks,
Oleg
  
Roman Scherer Dec. 8, 2024, 2:18 p.m. UTC | #3
References: <87y10q73sd.fsf@gmail.com>
	<8403c5159deb34bf4dac119d55c57c9dba530a20.1733594283.git.roman@burningswell.com>
	<handler.74728.D74728.173366126726317.notifdone@debbugs.gnu.org>
User-Agent: mu4e 1.12.7; emacs 29.4
Hi Oleg,

thanks for applying my patch. I now tried to build python-asyncssh from the
Guix master branch, but unfortunatly now other tests started to fail, which
didn't fail before for some reason.

I guess you don't see those issues, so maybe it is specific to my aarch64 system?

I sent a new mail and added a new patch that disables more tests. Could you
take a look at them?

Thanks, Roman.

Date: Sun, 08 Dec 2024 15:18:14 +0100

help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Your bug report
>
> #74728: [PATCH] gnu: python-asyncssh: Disable flaky connection tests.
>
> which was filed against the guix-patches package, has been closed.
>
> The explanation is attached below, along with your original report.
> If you require more details, please reply to 74728@debbugs.gnu.org.
>
> --
> 74728: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=74728
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Subject: [PATCH] gnu: python-asyncssh: Disable flaky connection tests.
> To: 74728-done@debbugs.gnu.org
> Date: Sun, 08 Dec 2024 12:33:22 +0000 (1 hour, 42 minutes, 21 seconds ago)
>
>
>
> Hi,
>
> Pushed as f2ad73507b9a313024893e837aa11774f61b273f to master.
>
> --
> Thanks,
> Oleg
>
> ----------
>
> From: Roman Scherer <roman@burningswell.com>
> Subject: [PATCH] gnu: python-asyncssh: Disable flaky connection tests.
> To: guix-patches@gnu.org
> Cc: Roman Scherer <roman@burningswell.com>
> Date: Sat,  7 Dec 2024 19:00:20 +0100
> Date: Sat,  7 Dec 2024 19:00:20 +0100 (20 hours, 15 minutes, 23 seconds ago)
>
> * gnu/packages/ssh.scm (python-asyncssh): Disable flaky connection tests.
>
> Change-Id: If99cc686679fd2c731f3d66a85abe23eff6f1234
> ---
>  gnu/packages/ssh.scm | 10 +++++++++-
>  1 file changed, 9 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
> index 1f33259246..a44976b598 100644
> --- a/gnu/packages/ssh.scm
> +++ b/gnu/packages/ssh.scm
> @@ -833,7 +833,15 @@ (define-public python-asyncssh
>                 ;; TODO Test fails for unknown reason
>                 (("(.+)async def test_confirm" all indent)
>                  (string-append indent "@unittest.skip('disabled by guix')\n"
> -                               indent "async def test_confirm")))))
> +                               indent "async def test_confirm")))
> +             (substitute* "tests/test_connection.py"
> +               ;; Tests fail with: asyncssh.misc.ConnectionLost: Connection lost
> +               (("(.+)async def test_get_server_host_key_proxy" all indent)
> +                (string-append indent "@unittest.skip('disabled by guix')\n"
> +                               indent "async def test_get_server_host_key_proxy"))
> +               (("(.+)async def test_connect_reverse_proxy" all indent)
> +                (string-append indent "@unittest.skip('disabled by guix')\n"
> +                               indent "async def test_connect_reverse_proxy")))))
>           (replace 'check
>             (lambda* (#:key tests? inputs outputs #:allow-other-keys)
>               (when tests?
>
> base-commit: bc630c5ebed27edd821ec363706f8b9cf1ee05cc
  
Sharlatan Hellseher Dec. 9, 2024, 9:27 p.m. UTC | #4
Hi,

[PATCH] gnu: python-asyncssh: Disable failing tests on aarch64.
Pushed as ec1a67d4ff7435fdf50de35c3f57d2f60a9cccf9 to master.

It was built successfully both on x86_68 and aarch64 in Qemu.

Pleas, open other issue if you find something else ;-).

--
Thanks,
Oleg
  

Patch

diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 1f33259246..a44976b598 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -833,7 +833,15 @@  (define-public python-asyncssh
                ;; TODO Test fails for unknown reason
                (("(.+)async def test_confirm" all indent)
                 (string-append indent "@unittest.skip('disabled by guix')\n"
-                               indent "async def test_confirm")))))
+                               indent "async def test_confirm")))
+             (substitute* "tests/test_connection.py"
+               ;; Tests fail with: asyncssh.misc.ConnectionLost: Connection lost
+               (("(.+)async def test_get_server_host_key_proxy" all indent)
+                (string-append indent "@unittest.skip('disabled by guix')\n"
+                               indent "async def test_get_server_host_key_proxy"))
+               (("(.+)async def test_connect_reverse_proxy" all indent)
+                (string-append indent "@unittest.skip('disabled by guix')\n"
+                               indent "async def test_connect_reverse_proxy")))))
          (replace 'check
            (lambda* (#:key tests? inputs outputs #:allow-other-keys)
              (when tests?