diff mbox series

[bug#65801] gnu: openmpi: Enable PMIx.

Message ID 840372D7-8A24-495D-8975-392DFFFA50C0@ufz.de
State New
Headers show
Series [bug#65801] gnu: openmpi: Enable PMIx. | expand

Commit Message

Lars Bilke Sept. 7, 2023, 1:13 p.m. UTC
Enables support for the Process Management Interface for Exascale which is used e.g. by Slurm for the management communication and coordination of MPI processes.

This allows e.g. to run guix-created container on JSC Juwels cluster with native performance.
From 23a11683c37faf8b971628b2ded9560ba5a22965 Mon Sep 17 00:00:00 2001
From: Lars Bilke <lars.bilke@ufz.de>
Date: Thu, 7 Sep 2023 15:06:03 +0200
Subject: [PATCH] [PATCH] gnu: openmpi: Enable PMIx.

Enables support for the Process Management Interface for Exascale which
is used e.g. by Slurm for the management communication and coordination
of MPI processes
---
 gnu/packages/mpi.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ludovic Courtès Sept. 14, 2023, 8:57 p.m. UTC | #1
Hi,

Lars Bilke <lars.bilke@ufz.de> skribis:

> Enables support for the Process Management Interface for Exascale which is used e.g. by Slurm for the management communication and coordination of MPI processes.
>
> This allows e.g. to run guix-created container on JSC Juwels cluster with native performance.

Nice.

Out of curiosity, does the cluster run Guix natively or are you using
‘guix pack’?

>>From 23a11683c37faf8b971628b2ded9560ba5a22965 Mon Sep 17 00:00:00 2001
> From: Lars Bilke <lars.bilke@ufz.de>
> Date: Thu, 7 Sep 2023 15:06:03 +0200
> Subject: [PATCH] [PATCH] gnu: openmpi: Enable PMIx.
>
> Enables support for the Process Management Interface for Exascale which
> is used e.g. by Slurm for the management communication and coordination
> of MPI processes

I added this to the comment in the code, tweaked the commit log, and
committed.

Thank you!

Ludo’.
Lars Bilke Sept. 15, 2023, 6:21 a.m. UTC | #2
Hi Ludo,

thanks for committing!

The JSC clusters don't run Guix natively but with the patch I can run 'guix pack' created containers with Apptainer with full interconnect perfomance! Thank you for all your work in this regard! Next up is to test the same container on other HPC platforms (already successfully tested on our in-house cluster EVE).

Sincerely,
Lars

On 14 Sep 2023, at 22:59, GNU bug Tracking System wrote:

> Your bug report
>
> #65801: [PATCH] gnu: openmpi: Enable PMIx.
>
> which was filed against the guix-patches package, has been closed.
>
> The explanation is attached below, along with your original report.
> If you require more details, please reply to 65801@debbugs.gnu.org.
>
> -- 
> 65801: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=65801
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
Ludovic Courtès Sept. 15, 2023, 9:09 a.m. UTC | #3
Hello,

Lars Bilke <lars.bilke@ufz.de> skribis:

> The JSC clusters don't run Guix natively but with the patch I can run
> 'guix pack' created containers with Apptainer with full interconnect
> perfomance! Thank you for all your work in this regard!

Excellent, good to hear!

> Next up is to test the same container on other HPC platforms (already
> successfully tested on our in-house cluster EVE).

Cool, let me know how it goes (we’re also using the same MPI on a range
of clusters in France).

Also next: getting sysadmins to consider installing Guix?  :-)

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 4d2458344f..907cd3af29 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -247,6 +247,10 @@  (define-public openmpi
                             "--enable-openib-rdmacm"
                             "--enable-openib-rdmacm-ibaddr"
 
+                            ;; Enable support for the 'Process Management
+                            ;; Interface for Exascale'.
+                            "--with-pmix=internal"
+
                             ;; Enable support for SLURM's Process Manager
                             ;; Interface (PMI).
                             ,(string-append "--with-pmi="