* gnu/packages/guile-xyz.scm (guile-fibers): When cross-building for the Hurd,
add "fix-env" phase.
Change-Id: Iebe12941bbfb2f5a6208f9364115e95f10e82ed6
---
gnu/packages/guile-xyz.scm | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)
@@ -9,7 +9,7 @@
;;; Copyright © 2016, 2017, 2021 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016, 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
;;; Copyright © 2016, 2021 Amirouche <amirouche@hypermove.net>
-;;; Copyright © 2016, 2019, 2021, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016, 2019, 2021, 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017 David Thompson <davet@gnu.org>
;;; Copyright © 2017, 2018, 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -875,7 +875,14 @@ (define-public guile-fibers
(substitute* "tests/basic.scm"
((".*spawn-fiber-chain 5000000.*") ""))
(substitute* "tests/channels.scm"
- ((".*assert-run-fibers-terminates .*pingpong.*") "")))))))))
+ ((".*assert-run-fibers-terminates .*pingpong.*") "")))))
+ #$@(if (and (target-hurd?) (%current-target-system))
+ #~((add-before 'build 'fixup-env
+ (lambda _
+ (substitute* "env"
+ ((".*override.*" all)
+ (string-append "true #" all))))))
+ '())))))
(native-inputs
(list texinfo pkg-config autoconf-2.71 automake libtool
guile-3.0 ;for 'guild compile