diff mbox series

[bug#67473,gnome-team,v3,09/14] gnu: lbsoup-minimal: Update to 3.4.4.

Message ID 8371fc9de5584de1870d733660224311ef1d9ce2.1701532196.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#67473,gnome-team,v3,01/14] gnu: gdk-pixbuf: Update to 2.42.10. | expand

Commit Message

Vivien Kraus Dec. 2, 2023, 3:08 p.m. UTC
The libsoup-minimal comment about inkscape is irrelevant, because inkscape
uses libsoup-minimal-2.

The option to build documentation has changed between libsoup 2 and libsoup 3.
The failing socket test has been moved to a different file.

libsoup-minimal-2 introduces a new phase to disable tests, however the
'adjust-tests phase of libsoup-minimal must be removed. For simplicity, we use
the 'adjust-tests name for the phase of all variants.

* gnu/packages/gnome.scm (libsoup-minimal): Update to 3.4.4.
[#:configure-flags]: Change name of docs option.
[#:phases]<adjust-test>: Change the file name of socket test.
(libsoup-minimal-2) [arguments]: Override #:configure-flags.
[#:phases]: Override 'adjust-tests.
(libsoup) [version]: Remove field.
[source]: Remove field.
[#:configure-flags]: Replace -Ddocs=disabled with -Ddocs=enabled.

Change-Id: Iace1bf0f1d805a0eed7e484a7cd496ac04631b32
---
 gnu/packages/gnome.scm | 28 ++++++++++++----------------
 1 file changed, 12 insertions(+), 16 deletions(-)

Comments

Liliana Marie Prikler Dec. 2, 2023, 4:34 p.m. UTC | #1
Am Samstag, dem 02.12.2023 um 16:08 +0100 schrieb Vivien Kraus:
> The libsoup-minimal comment about inkscape is irrelevant, because
> inkscape uses libsoup-minimal-2.
> 
> The option to build documentation has changed between libsoup 2 and
> libsoup 3. The failing socket test has been moved to a different
> file.
> 
> libsoup-minimal-2 introduces a new phase to disable tests, however
> the
> 'adjust-tests phase of libsoup-minimal must be removed. For
> simplicity, we use
> the 'adjust-tests name for the phase of all variants.
> 
> * gnu/packages/gnome.scm (libsoup-minimal): Update to 3.4.4.
> [#:configure-flags]: Change name of docs option.
> [#:phases]<adjust-test>: Change the file name of socket test.
> (libsoup-minimal-2) [arguments]: Override #:configure-flags.
> [#:phases]: Override 'adjust-tests.
> (libsoup) [version]: Remove field.
> [source]: Remove field.
> [#:configure-flags]: Replace -Ddocs=disabled with -Ddocs=enabled.
> 
> Change-Id: Iace1bf0f1d805a0eed7e484a7cd496ac04631b32
> ---
You typo'd in the subject line: it's libsoup, not lbsoup.

Lexically, the change LGTM, semantically CI may or may not have us
covered :)
Anyhow, queuing for Dec 10th.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7baef6ae5d..090335e6ff 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5004,11 +5004,10 @@  (define-public libshumate
 as OpenStreetMap, OpenCycleMap, OpenAerialMap and Maps.")
     (license license:lgpl2.1+)))
 
-;;; A minimal version of libsoup used to prevent a cycle with Inkscape.
 (define-public libsoup-minimal
   (package
     (name "libsoup-minimal")
-    (version "3.0.7")
+    (version "3.4.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/libsoup/"
@@ -5016,17 +5015,17 @@  (define-public libsoup-minimal
                                   "libsoup-" version ".tar.xz"))
               (sha256
                (base32
-                "1j7p3cz6hwi9js9rp0pbas7cdln97yg9v2l1nv5imhcr6p7r1pzb"))))
+                "1an5n2sa70f40my4g20lk38s5ib99c32bzzg8gm91v9nbxr6f719"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Dgtk_doc=false")
+     `(#:configure-flags '("-Ddocs=disabled")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'adjust-tests
            (lambda _
              ;; This test fails due to missing /etc/nsswitch.conf
              ;; in the build environment.
-             (substitute* "tests/socket-test.c"
+             (substitute* "tests/unix-socket-test.c"
                ((".*/sockets/unconnected.*") ""))
 
              ;; These fail because "subdomain.localhost" does not resolve in
@@ -5082,9 +5081,13 @@  (define-public libsoup-minimal-2
                 "04rgv6hkyhgi7lak9865yxgbgky6gc635p7w6nhcbj64rx0prdz4"))))
     (arguments
      (substitute-keyword-arguments (package-arguments libsoup-minimal)
+       ((#:configure-flags configure-flags)
+        ;; The option named changed between libsoup 2 and libsoup 3.
+        #~(cons "-Dgtk_doc=false"
+                (delete "-Ddocs=disabled" #$configure-flags)))
        ((#:phases phases)
         `(modify-phases ,phases
-           (add-after 'unpack 'disable-failing-tests
+           (replace 'adjust-tests
              (lambda _
                ;; Disable the SSL test, failing since 2.68 and resolved in
                ;; libsoup 3.
@@ -5097,20 +5100,13 @@  (define-public libsoup-minimal-2
 (define-public libsoup
   (package/inherit libsoup-minimal
     (name "libsoup")
-    (version "3.4.4")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/libsoup/"
-                                  (version-major+minor version) "/"
-                                  "libsoup-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1an5n2sa70f40my4g20lk38s5ib99c32bzzg8gm91v9nbxr6f719"))))
     (outputs (cons "doc" (package-outputs libsoup-minimal)))
     (arguments
      (substitute-keyword-arguments (package-arguments libsoup-minimal)
        ((#:configure-flags configure-flags)
-        #~(delete "-Dgtk_doc=false" #$configure-flags))
+        #~(cons "-Ddocs=enabled"
+                ;; The default value is 'auto', meaning it could be skipped.
+                (delete "-Ddocs=disabled" #$configure-flags)))
        ((#:phases phases)
         #~(modify-phases #$phases
             (replace 'adjust-tests