diff mbox series

[bug#38124] gnu: Add zam-plugins.

Message ID 8371d54f6514ae6eef11caceb0f08182@posteo.net
State Accepted
Headers show
Series [bug#38124] gnu: Add zam-plugins. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 10:39 a.m. UTC
NOTE: This patch depends on 
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38121

 From 03620d73893a4eb53cc294f653c72df0e945f9d5 Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:35:27 +0000
Subject: [PATCH] gnu: Add zam-plugins.

* gnu/packages/music.scm: (zam-plugins): New variable.
---
  gnu/packages/music.scm | 48 ++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 48 insertions(+)

+includes ZaMaximX2, ZamAutoSat, ZamComp, ZamCompX2, ZamEQ2, ZamGEQ31,
+ZamHeadX2, ZamPhono, ZamGate, ZamGateX2, ZamTube, ZamDelay, 
ZamDynamicEQ,
+ZaMultiComp, ZaMultiCompX2 and ZamSynth.")
+    (home-page "http://www.zamaudio.com/?p=976")
+    (license license:gpl2+)))

Comments

Marius Bakke Nov. 10, 2019, 10:10 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> NOTE: This patch depends on 
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38121
>
>  From 03620d73893a4eb53cc294f653c72df0e945f9d5 Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:35:27 +0000
> Subject: [PATCH] gnu: Add zam-plugins.
>
> * gnu/packages/music.scm: (zam-plugins): New variable.

Like the other patches, please resend it (preferably through 'git
send-email') after adjusting the indentation.

[...]

> +(define-public zam-plugins
> +  (package
> +    (name "zam-plugins")
> +    (version "3.11")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/zamaudio/zam-plugins.git")
> +               (commit version)
> +               (recursive? #t))) ; for DPF

Can you describe what DPF is?  Is it possible to package it separately?

> +        (file-name (string-append name "-" version))
> +        (sha256
> +          (base32
> +            "0jlbxm0g93plgd3g4r9rsr0c7868ms49bs0ljpqb6kw6132hsapp"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f  ; no "check" target
> +       #:make-flags
> +       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
> +             "HAVE_ZITA_CONVOLVER=true")
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-before 'build 'set-CC-variable
> +           (lambda _ (setenv "CC" "gcc") #t))
> +         (delete 'configure))))
> +    (inputs
> +     `(("fftwf" ,fftwf)
> +       ("jack" ,jack-1)
> +       ("liblo" ,liblo)
> +       ("libsamplerate" ,libsamplerate)
> +       ("mesa" ,mesa)
> +       ("zita-convolver" ,zita-convolver)))
> +    (native-inputs
> +     `(("ladspa" ,ladspa)
> +       ("lv2" ,lv2)
> +       ("pkg-config" ,pkg-config)))
> +    (synopsis "Collection of LADSPA/LV2/VST2/JACK audio processing 
> plugins")

Maybe just "Audio processing plugins"?  I suppose even more will be
supported in the future :-)
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..616b4dc370 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@ 
  ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
  ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -4699,3 +4700,50 @@  You can also get metadata about the playing track 
such as the artist and title
  for integration into status line generators or other command-line 
tools.")
      (home-page "https://github.com/altdesktop/playerctl")
      (license license:lgpl3+)))
+
+(define-public zam-plugins
+  (package
+    (name "zam-plugins")
+    (version "3.11")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/zamaudio/zam-plugins.git")
+               (commit version)
+               (recursive? #t))) ; for DPF
+        (file-name (string-append name "-" version))
+        (sha256
+          (base32
+            "0jlbxm0g93plgd3g4r9rsr0c7868ms49bs0ljpqb6kw6132hsapp"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             "HAVE_ZITA_CONVOLVER=true")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-CC-variable
+           (lambda _ (setenv "CC" "gcc") #t))
+         (delete 'configure))))
+    (inputs
+     `(("fftwf" ,fftwf)
+       ("jack" ,jack-1)
+       ("liblo" ,liblo)
+       ("libsamplerate" ,libsamplerate)
+       ("mesa" ,mesa)
+       ("zita-convolver" ,zita-convolver)))
+    (native-inputs
+     `(("ladspa" ,ladspa)
+       ("lv2" ,lv2)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Collection of LADSPA/LV2/VST2/JACK audio processing 
plugins")
+    (description
+     "Zam plugins is a collection of audio processing plugins in the 
LADSPA,
+LV2 and VST2 formats, as well as standalone JACK versions. The 
collection