diff mbox series

[bug#67281] gnu: tinmop: Update to 0.9.9.1414213.

Message ID 83712e175613fc0a039ca05cadfac62cf42babd2.1700402305.git.cage-dev@twistfold.it
State New
Headers show
Series [bug#67281] gnu: tinmop: Update to 0.9.9.1414213. | expand

Commit Message

cage Nov. 19, 2023, 1:59 p.m. UTC
Change-Id: Icbd516612296ee447edf569756dc38914240ae3b
---
 gnu/packages/web-browsers.scm | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)


base-commit: 5cad6f721b8884b612178896f06cd69d5839402c
prerequisite-patch-id: c248550a3e3ec5ebe9c44aa16d9e68888a7859f1
--
2.41.0

Comments

Guillaume Le Vaillant Nov. 20, 2023, 1:50 p.m. UTC | #1
Patch applied as 9cb0b33771b38adef8bed627d72a5e31c738f25f.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d38882046d..4b472f81ac 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -95,6 +95,7 @@  (define-module (gnu packages web-browsers)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages sqlite)
+  #:use-module (gnu packages tcl)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages webkit)
   #:use-module (gnu packages xorg))
@@ -852,16 +853,16 @@  (define-public bombadillo
 (define-public tinmop
   (package
     (name "tinmop")
-    (version "0.9.9.141")
+    (version "0.9.9.1414213")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://notabug.org/cage/tinmop")
+             (url "https://codeberg.org/cage/tinmop")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0hx52kaq0q9iccalkxk50q1v3mf9ypardjgv56d5sdrbhfqyashl"))))
+        (base32 "0rlgnqld6ls46452xvcr8k4ji4lwmlsrxib5ii9l9clkm0s477wv"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf
@@ -872,6 +873,7 @@  (define-public tinmop
            nano
            openssl
            sbcl
+           tk
            unzip
            xdg-utils))
     (inputs
@@ -893,10 +895,12 @@  (define-public tinmop
            sbcl-crypto-shortcuts
            sbcl-drakma
            sbcl-esrap
+           sbcl-flexi-streams
            sbcl-ieee-floats
            sbcl-local-time
            sbcl-log4cl
            sbcl-marshal
+           sbcl-nodgui
            sbcl-osicat
            sbcl-parse-number
            sbcl-percent-encoding
@@ -907,6 +911,7 @@  (define-public tinmop
            sbcl-trivial-clipboard
            sbcl-unix-opts
            sbcl-usocket
+           sbcl-yason
            sqlite))
     (arguments
      `(#:tests? #f
@@ -937,10 +942,10 @@  (define-public tinmop
                    "--eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\"  "))))
              #t)))))
     (synopsis
-     "Gemini, gopher, kami and pleroma client with a terminal interface")
+     "Gemini, gopher, kami and mastodon/pleroma client with a terminal interface")
     (description
-     "This package provides a Gemini, gopher, kami and pleroma client with a
-terminal interface.")
+     "This package provides a Gemini, gopher, kami and mastodon/pleroma client with a
+terminal interface, for Gemini also a GUI is available.")
     (home-page "https://www.autistici.org/interzona/tinmop.html")
     (license license:gpl3+)))