diff mbox series

[bug#64761,v3] gnu: odamex: Update to 10.4.0.

Message ID 832681d137a16d729637f875282aa1147ad8d045.1706366518.git.david@pflug.io
State New
Headers show
Series [bug#64761,v3] gnu: odamex: Update to 10.4.0. | expand

Commit Message

David Pflug Jan. 27, 2024, 2:41 p.m. UTC
* gnu/packages/games.scm (odamex): Update to 10.4.0.

I don't really know CMake, but ldd says all the libraries are from other parts of /gnu/store, so I *think* this unbundles? I'm not sure if that's the best way to check.

Change-Id: I371d18498640e15a7bfae527fea12d9432368f50
---
 gnu/packages/games.scm | 25 +++++++++++++++----------
 1 file changed, 15 insertions(+), 10 deletions(-)


base-commit: 3821ee62ccfe21b83d82f313c84497dd9980a0e6

Comments

Liliana Marie Prikler Jan. 27, 2024, 3:28 p.m. UTC | #1
Am Samstag, dem 27.01.2024 um 09:41 -0500 schrieb David Pflug:
> * gnu/packages/games.scm (odamex): Update to 10.4.0.
> 
> I don't really know CMake, but ldd says all the libraries are from
> other parts of /gnu/store, so I *think* this unbundles? I'm not sure
> if that's the best way to check.
> 
> Change-Id: I371d18498640e15a7bfae527fea12d9432368f50
> ---
You could delete the local sources with a snippet to make sure.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c6aa873ac7..45541598c5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -60,7 +60,7 @@ 
 ;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
-;;; Copyright © 2021 David Pflug <david@pflug.io>
+;;; Copyright © 2021, 2024 David Pflug <david@pflug.io>
 ;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021, 2022 Noisytoot <ron@noisytoot.org>
@@ -8096,26 +8096,31 @@  (define-public gzdoom
 (define-public odamex
   (package
     (name "odamex")
-    (version "0.9.5")
+    (version "10.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "mirror://sourceforge/odamex/Odamex/" version "/"
-             "odamex-src-" version ".tar.bz2"))
+             "odamex-src-" version ".tar.xz"))
        (sha256
-        (base32 "1x0c9vnwn336inkfamh4na8xjyfjmzfxfn49j4snqymkypjqw6jq"))))
+        (base32 "1isrmki18471yry48mmm7lxzp1kiqma9cc7fx38cvpm2mpgfyvzk"))))
     (build-system cmake-build-system)
-    (arguments `(#:tests? #f))          ; no tests
+    (arguments `(#:tests? #f))
     (native-inputs
      (list deutex))
     (inputs
-     `(("sdl" ,sdl2)
-       ("sdl-mixer" ,sdl2-mixer)
-       ("zlib" ,zlib)
-       ("libpng" ,libpng)
+     `(("alsa-lib" ,alsa-lib)
        ("curl" ,curl)
-       ("alsa-lib" ,alsa-lib)))
+       ("fltk" ,fltk)
+       ("jsoncpp" ,jsoncpp)
+       ("libpng" ,libpng)
+       ("miniupnpc" ,miniupnpc)
+       ("portmidi" ,portmidi)
+       ("protobuf" ,protobuf)
+       ("sdl" ,sdl2)
+       ("sdl-mixer" ,sdl2-mixer)
+       ("zlib" ,zlib)))
     (home-page "https://odamex.net/")
     (synopsis "Multiplayer Doom port")
     (description "Odamex is a modification of the Doom engine that