[bug#75641,v2] gnu: Add woof-doom.
Commit Message
* gnu/packages/games.scm (woof-doom): New variable.
Change-Id: I77cfa0fd2f2a20d6eee5d0339b9673899bb0ecad
---
Now linted and updated.
gnu/packages/games.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
base-commit: f2b3c36bee8c232b026a66de93db38e13fbd7076
@@ -8718,6 +8718,43 @@ (define-public crispy-doom
original.")
(home-page "https://www.chocolate-doom.org/wiki/index.php/Crispy_Doom")))
+(define-public woof-doom
+ (package
+ (name "woof-doom")
+ (version "15.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fabiangreffrath/woof")
+ (commit (string-append "woof_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04c7hm4jnr9aiz6w4520zww6b7j86qv9xaf87hdv48cjc9sp2ljk"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f))
+ (native-inputs (list python))
+ (inputs (list sdl2
+ sdl2-net
+ openal
+ libsndfile
+ libebur128
+ yyjson
+ fluidsynth
+ libxmp))
+ (home-page "https://github.com/fabiangreffrath/woof")
+ (synopsis "MBF-style Doom source port targeted at modern systems")
+ (description
+ "Woof! is a continuation of the MBF lineage of Doom source ports, with
+modern features such as dynamic resolution scaling, uncapped framerates,
+adjustable field of view, 3D audio with HRTF and 7.1 surround sound
+support, and modern gamepad features including rumble, gyro, and flick
+stick support. Supports the new MBF21 format, as well as the MUSINFO,
+UMAPINFO, DEHEXTRA, and DSDHacked specifictions.")
+ (license license:gpl2+)))
+
(define xonotic-data
(package
(name "xonotic-data")