diff mbox series

[bug#68207,v3,3/5] gnu: Add python-pygments-next.

Message ID 82e83109c6208911b5e64cfe9571f37bbf57e82d.1707761051.git.felgru@posteo.net
State New
Headers show
Series Update python-textual to 0.50.1. | expand

Commit Message

Felix Gruber Feb. 12, 2024, 6:04 p.m. UTC
* gnu/packages/python-xyz.scm (python-pygments-next): New variable.

Change-Id: I12e3e0d6042f34e0375bcbb1dc90ccc9ed9ce050
---
 gnu/packages/python-xyz.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30f6f1fb3e..b3eed56d06 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6588,6 +6588,21 @@  (define-public python-pygments
      "Pygments is a syntax highlighting package written in Python.")
     (license license:bsd-2)))
 
+(define-public python-pygments-next
+  (package
+    (inherit python-pygments)
+    (name "python-pygments-next")
+    (version "2.17.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pygments" version))
+       (sha256
+        (base32
+         "0ry3qi4rszkiqb20bmjlzys71dja9i746kvqi8xbxr9dzp4wwins"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-hatchling))))
+
 (define-public python-pygments-github-lexers
   (package
     (name "python-pygments-github-lexers")