diff mbox series

[bug#64787,1/2] gnu: Add scummc.

Message ID 82cbd1ec-be9b-bd78-79a4-0c375d0f5c57@disroot.org
State New
Headers show
Series gnu: Add openquest. | expand

Commit Message

Adam Faiz July 22, 2023, 8:24 a.m. UTC
From 7b2abb3e398601b28666511b457c23f2e2b71a79 Mon Sep 17 00:00:00 2001
Message-ID: <7b2abb3e398601b28666511b457c23f2e2b71a79.1690012542.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1690012542.git.adam.faiz@disroot.org>
References: <cover.1690012542.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sat, 22 Jul 2023 15:34:55 +0800
Subject: [PATCH 1/2] gnu: Add scummc.

* gnu/packages/game-development.scm (scummc): New variable.
---
 gnu/packages/game-development.scm | 44 +++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

Comments

Liliana Marie Prikler July 22, 2023, 9:14 a.m. UTC | #1
Am Samstag, dem 22.07.2023 um 16:24 +0800 schrieb Adam Faiz:
> From 7b2abb3e398601b28666511b457c23f2e2b71a79 Mon Sep 17 00:00:00
> 2001
> Message-ID:
> <7b2abb3e398601b28666511b457c23f2e2b71a79.1690012542.git.adam.faiz@di
> sroot.org>
> In-Reply-To: <cover.1690012542.git.adam.faiz@disroot.org>
> References: <cover.1690012542.git.adam.faiz@disroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Sat, 22 Jul 2023 15:34:55 +0800
> Subject: [PATCH 1/2] gnu: Add scummc.
> 
> * gnu/packages/game-development.scm (scummc): New variable.
> ---
>  gnu/packages/game-development.scm | 44
> +++++++++++++++++++++++++++++++
>  1 file changed, 44 insertions(+)
> 
> diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-
> development.scm
> index b0d9a88dc2..a2600ff2fe 100644
> --- a/gnu/packages/game-development.scm
> +++ b/gnu/packages/game-development.scm
> @@ -66,6 +66,7 @@ (define-module (gnu packages game-development)
>    #:use-module (gnu packages autotools)
>    #:use-module (gnu packages base)
>    #:use-module (gnu packages bash)
> +  #:use-module (gnu packages bison)
>    #:use-module (gnu packages boost)
>    #:use-module (gnu packages build-tools)
>    #:use-module (gnu packages compression)
> @@ -745,6 +746,49 @@ (define-public tsukundere
>  experimental.")
>      (license license:lgpl3+)))
>  
> +(define-public scummc
> +  (package
> +    (name "scummc")
> +    (version "0.2.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/AlbanBedel/scummc")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "1yyq05kfmvgx5aa68kg1l5a4lpsky7hzxxcdvv2xbgf0jljdcl3k"))))
> +    (build-system gnu-build-system)
> +    (native-inputs
> +     (list bison doxygen libxslt pkg-config))
> +    (inputs
> +     (list freetype gtk+-2 sdl))
> +    (arguments
> +     (list #:test-target "test"
> +           #:tests? #f ; The only tests verify that game checksums
> match
> +           #:make-flags
> +           #~(list "SHOW_WARNINGS=no")
> +           #:phases
> +           #~(modify-phases %standard-phases
> +               (replace 'configure ; ScummC uses a non-standard
> configure
> +                 (lambda _
> +                   (invoke "./configure")))
Replaced configure should still take #:configure-flags.
> +               (add-after 'build 'build-openquest
> +                 (lambda _
> +                   (with-directory-excursion "examples/openquest"
> +                     (invoke "make" "tentacle"))))
Is this a check?
> +               (replace 'install ; install target is referred to as
> distrib
> +                 (lambda _
> +                   (invoke "make" "distrib"
> +                           (string-append "DISTRIB=" #$output)))))))
> +    (synopsis "Scumm Compiler")
> +    (description
> +     "ScummC is a set of tools allowing to create SCUMM games from
> scratch.
> +It is capable of creating games for SCUMM version 6 and partially
> version 7.")
> +    (home-page "https://github.com/AlbanBedel/scummc")
> +    (license license:gpl2+)))
> +
Otherwise LGTM.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index b0d9a88dc2..a2600ff2fe 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -66,6 +66,7 @@  (define-module (gnu packages game-development)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages compression)
@@ -745,6 +746,49 @@  (define-public tsukundere
 experimental.")
     (license license:lgpl3+)))
 
+(define-public scummc
+  (package
+    (name "scummc")
+    (version "0.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/AlbanBedel/scummc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1yyq05kfmvgx5aa68kg1l5a4lpsky7hzxxcdvv2xbgf0jljdcl3k"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list bison doxygen libxslt pkg-config))
+    (inputs
+     (list freetype gtk+-2 sdl))
+    (arguments
+     (list #:test-target "test"
+           #:tests? #f ; The only tests verify that game checksums match
+           #:make-flags
+           #~(list "SHOW_WARNINGS=no")
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'configure ; ScummC uses a non-standard configure
+                 (lambda _
+                   (invoke "./configure")))
+               (add-after 'build 'build-openquest
+                 (lambda _
+                   (with-directory-excursion "examples/openquest"
+                     (invoke "make" "tentacle"))))
+               (replace 'install ; install target is referred to as distrib
+                 (lambda _
+                   (invoke "make" "distrib"
+                           (string-append "DISTRIB=" #$output)))))))
+    (synopsis "Scumm Compiler")
+    (description
+     "ScummC is a set of tools allowing to create SCUMM games from scratch.
+It is capable of creating games for SCUMM version 6 and partially version 7.")
+    (home-page "https://github.com/AlbanBedel/scummc")
+    (license license:gpl2+)))
+
 (define-public sfml
   (package
     (name "sfml")