diff mbox series

[bug#63199] gnu: Add juce.

Message ID 82Vq54ICY2wY3ste1ysyzh2OlgViC2d6cXej6r12bRJd1BcNtggmr6180ZNeCvNOoItWOTzDf-wx2KCQvHemXOy-NFD0Kq8XCfUCNfySEkc=@proton.me
State New
Headers show
Series [bug#63199] gnu: Add juce. | expand

Commit Message

Sughosha May 1, 2023, 5:49 a.m. UTC
* gnu/packages/cpp.scm (juce): New variable.
---
 gnu/packages/cpp.scm | 55 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)

--
libgit2 1.5.1
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 023d1c0..5945923 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -66,6 +66,7 @@ 
   #:use-module (guix gexp)
   #:use-module (gnu packages)
   #:use-module (gnu packages assembly)
+  #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages build-tools)
@@ -82,6 +83,7 @@ 
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages image)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages linux)
@@ -98,6 +100,7 @@ 
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages webkit)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (ice-9 match))
@@ -2430,6 +2433,58 @@  queues, resource pools, strings, etc.
 @end itemize")
       (license license:zlib))))
 
+(define-public juce
+  (package
+    (name "juce")
+    (version "7.0.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/juce-framework/JUCE")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1zfkyf9gwwvv0mrslvvjlh6gxv1zd50bkcal54x1kqil46hps49m"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f ;no test suite
+           #:configure-flags #~(list "-DJUCE_TOOL_INSTALL_DIR=bin")
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'fix-paths
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (substitute*
+                    "extras/Projucer/Source/ProjectSaving/jucer_ProjectExport_CodeBlocks.h"
+                     (("/usr/include/freetype2")
+                      (string-append #$freetype "/include/freetype2")))
+                   (substitute*
+                    "modules/juce_graphics/native/juce_linux_Fonts.cpp"
+                     (("/etc/fonts")
+                      (string-append #$fontconfig "/etc/fonts"))))))))
+    (native-inputs
+     (list alsa-lib
+           curl
+           jack-1
+           libx11
+           pkg-config
+           webkitgtk-with-libsoup2))
+    (inputs (list fontconfig freetype libjpeg-turbo libpng))
+    (home-page "https://juce.com")
+    (synopsis "Cross-platform C++ application framework")
+    (description
+     "JUCE is a cross-platform C++ application framework for creating
+applications including VST, VST3, AU, AUv3, AAX and LV2 audio plug-ins and
+plug-in hosts.")
+    (license
+     (list license:asl2.0 ;for Oboe and AudioUnitSDK
+           license:bsd-3 ;for FLAC, Ogg Vorbis and OpenGL Extension Wrangler
+           license:expat ;for Mesa 3-D graphics and jucer icons
+           license:gpl3 ;for JUCE and VST3 SDK
+           license:ijg ;for jpeglib
+           license:isc ;for LV2 SDK
+           license:zlib)))) ;for pngLib, zlib and Box2D
+
 (define-public ftxui
   (package
     (name "ftxui")