diff mbox series

[bug#69486,v2] gnu: Add python-pypugjs.

Message ID 82876190057cca585a3b936ec7e0ff03b31db318.1710692958.git.tanguy@bioneland.org
State New
Headers show
Series [bug#69486,v2] gnu: Add python-pypugjs. | expand

Commit Message

Tanguy LE CARROUR March 17, 2024, 4:32 p.m. UTC
Hi Guix,

V2 fixes problems reported by QA: `python-pip` and `python-setuptools`
should not be part of the inputs.

Tanguy

* gnu/packages/python-xyz.scm (python-pypugjs): New variable.

Change-Id: I050ab42d0149fcffddcf6b12dd9c1ddea23f84c9
Signed-off-by: Tanguy Le Carrour <tanguy@bioneland.org>
---
 gnu/packages/python-xyz.scm | 46 +++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)


base-commit: 93aefca7bab5f5b40164176e3224221d26d708f1
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 232b5d6999..e314ba9fab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6056,6 +6056,52 @@  (define-public python-jinja2-time
 templates.  A format string can be provided to control the output.")
     (license license:expat)))
 
+(define-public python-pypugjs
+  (package
+    (name "python-pypugjs")
+    (version "5.9.12")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/kakulukia/pypugjs")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zj7a560h973cl7brfw1nmyhgm8rp8j80wnih0shvhmw4ql23lpa"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   ;; Our pyramid is outdated and pyramid-mako is not packaged.
+                   (add-after 'unpack 'disable-pyramid
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       (substitute* "setup.py"
+                         (("'pyramid")
+                          "#'pyramid"))))
+                   (replace 'check
+                     (lambda* (#:key tests? #:allow-other-keys)
+                       (when tests?
+                         (invoke "python" "-m" "pytest" "-v"
+                                 "pypugjs/testsuite/")))))))
+    (native-inputs (list python-coverage
+                         python-django
+                         python-jinja2
+                         python-flake8
+                         python-flask
+                         python-mako
+                         python-nose
+                         python-poetry-core
+                         python-pytest
+                         python-tornado-6
+                         python-wheel))
+    (propagated-inputs (list python-charset-normalizer python-six))
+    (home-page "https://github.com/kakulukia/pypugjs")
+    (synopsis "Convert Pug source files into different template languages")
+    (description
+     "PugJS syntax template adapter for Django, Jinja2, Mako and Tornado templates.")
+    (license license:expat))) ;; MIT
+
 (define-public python-pysdl2
   (package
     (name "python-pysdl2")