diff mbox series

[bug#43357] Add Goxel into the package list

Message ID 826ac1fd-370c-65e6-98e8-4cf5807dacdc@gmail.com
State Accepted
Headers show
Series [bug#43357] Add Goxel into the package list | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Gabriel Arazas Sept. 12, 2020, 10:11 a.m. UTC
Hello again! I've been trying some digital arts thing so why not add 
Goxel ( https://github.com/guillaumechereau/goxel ) into the package list.

Attached to this email is the patch.

Comments

Ludovic Courtès Sept. 15, 2020, 12:41 p.m. UTC | #1
Hi,

Gabriel Arazas <foo.dogsquared@gmail.com> skribis:

>>From 0c1a4d2c4a897b0316bfe31ef6f0985f18d374dd Mon Sep 17 00:00:00 2001
> From: Gabriel Arazas <foo.dogsquared@gmail.com>
> Date: Sat, 12 Sep 2020 17:33:32 +0800
> Subject: [PATCH] gnu: Add goxel.
>
> * gnu/packages/graphics.scm (goxel): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 0c1a4d2c4a897b0316bfe31ef6f0985f18d374dd Mon Sep 17 00:00:00 2001
From: Gabriel Arazas <foo.dogsquared@gmail.com>
Date: Sat, 12 Sep 2020 17:33:32 +0800
Subject: [PATCH] gnu: Add goxel.

* gnu/packages/graphics.scm (goxel): New variable.
---
 gnu/packages/graphics.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index d6c8e415bb..bc7838320f 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -614,6 +615,39 @@  NOTE: This older version of Blender is the last release that does not require
 OpenGL 3.  It is retained for use with older computers.")
     (license license:gpl2+)))
 
+(define-public goxel
+  (package
+    (name "goxel")
+    (version "0.10.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/guillaumechereau/goxel")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1wmxy5wfk1xrqgz0y0zcr4vkddylqc70cv4vzk117x6whjnldsm3"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases (delete 'configure))
+       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                          "release")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gtk3" ,gtk+)
+       ("glfw" ,glfw)
+       ("scons" ,scons)))
+    (home-page "https://goxel.xyz/")
+    (synopsis "Voxel editor")
+    (description
+     "Goxel is a voxel editor that features unlimited scene size, unlimited
+history buffer, 24-bit RGB colors, layers, procedural rendering, ray tracing,
+and export to various formats including the format used by Magicavoxel.")
+    (license license:gpl3+)))
+
 (define-public assimp
   (package
     (name "assimp")
-- 
2.28.0