diff mbox series

[bug#73124,3/3] gnu: wlroots: Remove hwdata patch

Message ID 8259a901ab9814e5614b47eda2ccec3fd2577d12.1725815893.git.rutherther@protonmail.com
State New
Headers show
Series gnu: wlroots: update on mesa-updates | expand

Commit Message

Rutherther Sept. 8, 2024, 5:30 p.m. UTC
Hwdata has been updated and outputs "share/pkgconfig/hwdata.pc",
this patch is no longer necessary.

Change-Id: Ie4c8cd26fa5c1162004f096f037c658b103b02ae
---
 gnu/local.mk                                  |  1 -
 .../patches/wlroots-hwdata-fallback.patch     | 46 -------------------
 gnu/packages/wm.scm                           |  4 +-
 3 files changed, 1 insertion(+), 50 deletions(-)
 delete mode 100644 gnu/packages/patches/wlroots-hwdata-fallback.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index cf42e2b6da..4a2b1c1dbe 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2288,7 +2288,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/webrtc-audio-processing-x86-no-sse.patch	\
   %D%/packages/patches/webrtc-for-telegram-desktop-unbundle-libsrtp.patch \
   %D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch	\
-  %D%/packages/patches/wlroots-hwdata-fallback.patch		\
   %D%/packages/patches/wmctrl-64-fix.patch			\
   %D%/packages/patches/wmfire-dont-inline-draw-fire.patch	\
   %D%/packages/patches/wmfire-update-for-new-gdk-versions.patch	\
diff --git a/gnu/packages/patches/wlroots-hwdata-fallback.patch b/gnu/packages/patches/wlroots-hwdata-fallback.patch
deleted file mode 100644
index 6468c7cbf3..0000000000
--- a/gnu/packages/patches/wlroots-hwdata-fallback.patch
+++ /dev/null
@@ -1,46 +0,0 @@ 
-backend/drm: add hardcoded hwdata path fallback
-
-Add hardcoded fallback "/usr/share/hwdata/pnp.ids" as a
-temporary solution to get things working in Guix until
-hwdata ships with pkg-config file.
-
-diff --git a/backend/drm/meson.build b/backend/drm/meson.build
-index 6fcb2c15..ed95360a 100644
---- a/backend/drm/meson.build
-+++ b/backend/drm/meson.build
-@@ -1,8 +1,7 @@
- hwdata = dependency(
- 	'hwdata',
--	required: 'drm' in backends,
-+	required: false,
- 	native: true,
--	not_found_message: 'Required for the DRM backend.',
- )
- 
- libdisplay_info = dependency(
-@@ -19,15 +18,21 @@ libliftoff = dependency(
- 	required: false,
- )
- 
--if not (hwdata.found() and libdisplay_info.found() and features['session'])
-+if hwdata.found()
-+	hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
-+	pnp_ids = files(hwdata_dir / 'pnp.ids')
-+else
-+	pnp_ids = files('/usr/share/hwdata/pnp.ids')
-+endif
-+
-+if not (libdisplay_info.found() and features['session'])
- 	subdir_done()
- endif
- 
--hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
- pnpids_c = custom_target(
- 	'pnpids.c',
- 	output: 'pnpids.c',
--	input: files(hwdata_dir / 'pnp.ids'),
-+	input: pnp_ids,
- 	feed: true,
- 	capture: true,
- 	command: files('gen_pnpids.sh'),
-
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 238f4138ab..ed998101e7 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1735,8 +1735,7 @@  (define-public wlroots-0.18
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "13avi2805wrfkghgc7ar273p61svmm85k3g3hg9bf2gaxsz6f91f"))
-       (patches (search-patches "wlroots-hwdata-fallback.patch"))))
+        (base32 "13avi2805wrfkghgc7ar273p61svmm85k3g3hg9bf2gaxsz6f91f"))))
     (build-system meson-build-system)
     (arguments
      `(#:phases
@@ -1790,7 +1789,6 @@  (define-public wlroots-0.17
     (version "0.17.4")
     (source
      (origin
-       (inherit (package-source wlroots-0.18))
        (method git-fetch)
        (uri (git-reference
              (url "https://gitlab.freedesktop.org/wlroots/wlroots")