@@ -2288,7 +2288,6 @@ dist_patch_DATA = \
%D%/packages/patches/webrtc-audio-processing-x86-no-sse.patch \
%D%/packages/patches/webrtc-for-telegram-desktop-unbundle-libsrtp.patch \
%D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch \
- %D%/packages/patches/wlroots-hwdata-fallback.patch \
%D%/packages/patches/wmctrl-64-fix.patch \
%D%/packages/patches/wmfire-dont-inline-draw-fire.patch \
%D%/packages/patches/wmfire-update-for-new-gdk-versions.patch \
deleted file mode 100644
@@ -1,46 +0,0 @@
-backend/drm: add hardcoded hwdata path fallback
-
-Add hardcoded fallback "/usr/share/hwdata/pnp.ids" as a
-temporary solution to get things working in Guix until
-hwdata ships with pkg-config file.
-
-diff --git a/backend/drm/meson.build b/backend/drm/meson.build
-index 6fcb2c15..ed95360a 100644
---- a/backend/drm/meson.build
-+++ b/backend/drm/meson.build
-@@ -1,8 +1,7 @@
- hwdata = dependency(
- 'hwdata',
-- required: 'drm' in backends,
-+ required: false,
- native: true,
-- not_found_message: 'Required for the DRM backend.',
- )
-
- libdisplay_info = dependency(
-@@ -19,15 +18,21 @@ libliftoff = dependency(
- required: false,
- )
-
--if not (hwdata.found() and libdisplay_info.found() and features['session'])
-+if hwdata.found()
-+ hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
-+ pnp_ids = files(hwdata_dir / 'pnp.ids')
-+else
-+ pnp_ids = files('/usr/share/hwdata/pnp.ids')
-+endif
-+
-+if not (libdisplay_info.found() and features['session'])
- subdir_done()
- endif
-
--hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
- pnpids_c = custom_target(
- 'pnpids.c',
- output: 'pnpids.c',
-- input: files(hwdata_dir / 'pnp.ids'),
-+ input: pnp_ids,
- feed: true,
- capture: true,
- command: files('gen_pnpids.sh'),
-
@@ -1735,8 +1735,7 @@ (define-public wlroots-0.18
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "13avi2805wrfkghgc7ar273p61svmm85k3g3hg9bf2gaxsz6f91f"))
- (patches (search-patches "wlroots-hwdata-fallback.patch"))))
+ (base32 "13avi2805wrfkghgc7ar273p61svmm85k3g3hg9bf2gaxsz6f91f"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1790,7 +1789,6 @@ (define-public wlroots-0.17
(version "0.17.4")
(source
(origin
- (inherit (package-source wlroots-0.18))
(method git-fetch)
(uri (git-reference
(url "https://gitlab.freedesktop.org/wlroots/wlroots")