[bug#63991,v3,2/3] gnu: Add dmlc-core-next, as head of main branch of dmlc-core.
Commit Message
* gnu/packages/machine-learning.scm (dmlc-core-next): New variable.
Change-Id: Icf608b45b69cf020c213696644412664ba935e6d
---
gnu/packages/machine-learning.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)
@@ -3783,6 +3783,23 @@ (define-public dmlc-core
learning libraries.")
(license license:asl2.0)))
+(define-public dmlc-core-next
+ ; apache Tvm needs the latest CODE FROM git commits in May 2024 or later
+ (let ((commit "13341857549852a9a86b1894b5ba84c6276ab381"))
+ (package
+ (inherit dmlc-core)
+ (name "dmlc-core")
+ (version (string-append "0.5-1." (string-take commit 8)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dmlc/dmlc-core")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "1hj6h103lal3cm5mnry9lrm3d7aij89rxv46yv6y49vzd5hbnfbd")))))))
+
(define-public xgboost
(package
(name "xgboost")