diff mbox series

[bug#73647] gnu: Add indicator-sound-switcher.

Message ID 81ee4883a6a714b32146e01c99270d16ae7d44ff.1731415143.git.sebastian.willenbrink@gmail.com
State New
Headers show
Series [bug#73647] gnu: Add indicator-sound-switcher. | expand

Commit Message

Sebastian Willenbrink Nov. 12, 2024, 12:58 p.m. UTC
* gnu/packages/wm.scm (indicator-sound-switcher): New variable.

Change-Id: I013091cca83fc96c47b5a7ebe5ccfc7db1354ff1
---
 gnu/packages/wm.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)


base-commit: 40625c213ad2007f70117518a7cc290d367e652a
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 836d4b6c04..61f8d4a310 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -112,6 +112,7 @@  (define-module (gnu packages wm)
   #:use-module (gnu packages)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages admin)
+  #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
@@ -3969,3 +3970,41 @@  (define-public wf-config
 configuration files of Wayifre.  It can set key and mouse bindings,
 configure input, and customize Wayfire plugins.")
     (license license:expat)))
+
+(define-public indicator-sound-switcher
+  (package
+    (name "indicator-sound-switcher")
+    (version "2.3.10.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/yktoo/indicator-sound-switcher")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0y52k56ww2327r7ywwdvld5lx85qmcy8yrpaxc5lim7w3jbf3s85"))))
+    (build-system python-build-system)
+    (native-inputs (list gettext-minimal gobject-introspection))
+    (inputs (list python-pygobject girara python-pulsectl pulseaudio))
+    (propagated-inputs (list libappindicator keybinder))
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'install 'patch-xdg-autostart
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       (substitute* "setup.py"
+                         (("/etc/xdg/autostart")
+                          '"share/etc/xdg/autostart"))
+                       (substitute*
+                           "lib/indicator_sound_switcher/lib_pulseaudio.py"
+                         (("libpulse.so.0")
+                          (search-input-file inputs "/lib/libpulse.so.0"))))))))
+    (home-page "https://github.com/yktoo/indicator-sound-switcher")
+    (synopsis "Sound input/output selector indicator for Linux")
+    (description
+     "indicator-sound-switcher shows an icon in the indicator area or the system
+tray (whatever is available in your desktop environment). The icon's menu allows
+you to switch the current sound input and output (i.e. source ports and sink
+ports in PulseAudio's terms, respectively) with just two clicks.")
+    (license license:gpl3)))