@@ -112,6 +112,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages)
#:use-module (gnu packages bash)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -3969,3 +3970,41 @@ (define-public wf-config
configuration files of Wayifre. It can set key and mouse bindings,
configure input, and customize Wayfire plugins.")
(license license:expat)))
+
+(define-public indicator-sound-switcher
+ (package
+ (name "indicator-sound-switcher")
+ (version "2.3.10.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yktoo/indicator-sound-switcher")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y52k56ww2327r7ywwdvld5lx85qmcy8yrpaxc5lim7w3jbf3s85"))))
+ (build-system python-build-system)
+ (native-inputs (list gettext-minimal gobject-introspection))
+ (inputs (list python-pygobject girara python-pulsectl pulseaudio))
+ (propagated-inputs (list libappindicator keybinder))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'install 'patch-xdg-autostart
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "setup.py"
+ (("/etc/xdg/autostart")
+ '"share/etc/xdg/autostart"))
+ (substitute*
+ "lib/indicator_sound_switcher/lib_pulseaudio.py"
+ (("libpulse.so.0")
+ (search-input-file inputs "/lib/libpulse.so.0"))))))))
+ (home-page "https://github.com/yktoo/indicator-sound-switcher")
+ (synopsis "Sound input/output selector indicator for Linux")
+ (description
+ "indicator-sound-switcher shows an icon in the indicator area or the system
+tray (whatever is available in your desktop environment). The icon's menu allows
+you to switch the current sound input and output (i.e. source ports and sink
+ports in PulseAudio's terms, respectively) with just two clicks.")
+ (license license:gpl3)))