diff mbox series

[bug#71780,v2,3/7] gnu: Add go-github-com-boltdb-bolt.

Message ID 818b8327602b5e0a37ce8383385e5f178f11d28d.1719696984.git.woshilapin@tuziwo.info
State New
Headers show
Series [bug#71780,v2,1/7] gnu: go-github-com-emersion-go-pgpmail: Update to 0.2.1. | expand

Commit Message

woshilapin June 29, 2024, 9:36 p.m. UTC
* gnu/packages/golang.scm (go-github-com-boltdb-bolt): New variable.

Change-Id: I931688d0c32fc16a50cb58d4a7fef627d4e584a5
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d9145e9ac4..3daf97ec92 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -46,6 +46,7 @@ 
 ;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;; Copyright © 2024 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2024 Brennan Vincent <brennan@umanwizard.com>
+;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5731,6 +5732,32 @@  (define-public go-github-com-ddevault-go-libvterm
        "This is a fork of another go-libvterm library for use with aerc.")
       (license license:expat))))
 
+(define-public go-github-com-boltdb-bolt
+  (package
+    (name "go-github-com-boltdb-bolt")
+    (version "1.3.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/boltdb/bolt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0z7j06lijfi4y30ggf2znak2zf2srv2m6c68ar712wd2ys44qb3r"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/boltdb/bolt"
+      #:tests? #f))
+    (home-page "https://github.com/boltdb/bolt")
+    (synopsis "Pure Go key/value store inspired by Howard Chu's LMDB project")
+    (description
+     "Bolt is a pure Go key/value store inspired by Howard Chu's LMDB project.
+     The goal of the project is to provide a simple, fast, and reliable database
+     for projects that don't require a full database server such as Postgres or MySQL.")
+    (license license:expat)))
+
 (define-public go-github-com-emersion-go-imap
   (package
     (name "go-github-com-emersion-go-imap")